Closed Bug 1493916 Opened Last year Closed 3 months ago

fix ppc64 inline assembler for clang

Categories

(NSS :: Build, enhancement, P3)

Other
Unspecified
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dan, Assigned: dan)

Details

Attachments

(1 file)

Seems clang's inline assembler doesn't want registers to be prefixed with "r",
while gcc accepts both - r0 and 0 for GPR0.

tested with clang 6.0 and gcc 8.1
Attachment #9011723 - Flags: review?
Attachment #9011723 - Flags: review? → review?(jjones)
Assignee: nobody → dan
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Hardware: Unspecified → Other
Comment on attachment 9011723 [details] [diff] [review]
0003-fix-ppc64-inline-assembler-for-clang.patch

Review of attachment 9011723 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, matches the docs I've found, and the try run is also good:

https://treeherder.mozilla.org/#/jobs?repo=nss-try&revision=cb1a39c4226e&selectedJob=257744149

I'm sorry that this bug was hidden - I hadn't looked for r? with no one attached to it since I started being triage owner until this morning. Apologies for the lateness!
Attachment #9011723 - Flags: review?(jjones) → review+
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 3.46
You need to log in before you can comment on or make changes to this bug.