Closed Bug 1494014 Opened Last year Closed Last year

Incorrect thumbnail is displayed for "My Themes"

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: emilghitta, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Themes.gif
[Affected versions]:
Firefox 64.0a1 (BuildId:20180925100100).
Firefox 63.0b9 (BuildId:20180924202103).
Firefox 62.0.2 (BuildId:20180920131237).

[Unaffected versions]:
Firefox 60.2.1esr (BuildId:20180920175354).

[Affected platforms]:
Windows 10 64bit.
macOS 10.13.4
Ubuntu 16.04 64bit.

[Steps to reproduce]:
1. Launch Firefox.
2. Click the "Hamburger" menu.
3. Click the "Customize" button.
4. Change between "Default", "Light" and "Dark" themes.

[Expected result]:
The correct thumbnail is displayed for each selected theme.

[Actual result]:
The incorrect thumbnail is displayed.

[Regression range]

This seems to be a regression:

Last good revision: 72189b6ec0f192d7c26abaa8d449af3b94a11327
First bad revision: 510b02c8eb4c30437fd06058a6d46b827f0f1d78

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=72189b6ec0f192d7c26abaa8d449af3b94a11327&tochange=510b02c8eb4c30437fd06058a6d46b827f0f1d78

[Notes]
For further information regarding this issue please observe the attached screencast.
Hi Kris,

It seems that mozregression pointed out Bug 1467695 for causing this regression.

Can you please have a look?

Thanks!
Flags: needinfo?(kmaglione+bmo)
Component: Theme → Toolbars and Customization
Given this is a regression and the fix is likely fairly straightforward, let's try to get to this soon. Kris, let me know if you can't take this.
Priority: -- → P1
Gijs, can we find an owner and try to get this fixed in 65?
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6ce32daf8079
fix icon on the lightweight theme button to be correct when changing it from the menu, r=jaws
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/df7e7d55004d
Backed out changeset 6ce32daf8079 for browser chrome failures on browser_1007336_lwthemes_in_customize_mode. CLOSED TREE
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/929c91b8afc6
fix icon on the lightweight theme button to be correct when changing it from the menu, r=jaws
https://hg.mozilla.org/mozilla-central/rev/929c91b8afc6
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+
This issue is verified fixed using Firefox 65.0b8 (BuildId:20190103150357) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.