Clarification to reported Javascript:history.go(#); problem.

RESOLVED DUPLICATE of bug 146268

Status

()

Core
Document Navigation
--
trivial
RESOLVED DUPLICATE of bug 146268
16 years ago
9 years ago

People

(Reporter: James Grubic, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Hello:

I have done some more extensive testing on this problem, and wished to report my
results.

In Netscape 3/4x, IE 5.x, etc. the javascript:history.go(-3); jumps to a
specific previous page in a form-based site. These browsers all work
identically. Mozilla 1 .0 and Netscape 7 jump one page further back.

I believe that I now know why in our situation it is doing this. On our
form-based site, we use a <META HTTP-EQUIV="Refresh"
CONTENT="1;URL=http://www.testsite.com"> to get to a specific page automatically
(we do this to pass certain parameters to Lasso, a database manipulation tool).
It is my opinion that Mozilla 1.0/Netscape 7 is not counting this refresh page
in the history list, and the older browsers are.

This is of course a minor issue and I doubt that anyone else would ever see
this. It's easier for us to set up our site in a different way than it is for
you to go through mountains of code looking for a trivial problem. On regular
sites with no automatic refreshes, the javascript:history.go(#); works correctly.

Thank you, and keep up the great work on Mozilla.


James
-> History
Assignee: Matti → radha
Component: Browser-General → History: Session
QA Contact: imajes-qa → claudius

Comment 2

16 years ago
Resolving as dup of reporter's original bug 146268 and adding comment there.

*** This bug has been marked as a duplicate of 146268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.