Closed Bug 14941 Opened 21 years ago Closed 20 years ago

[DOGFOOD]if you have no previous profile and nothing to migrate no profile is written

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3, major)

x86
Linux

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 16414

People

(Reporter: andreas.otte, Assigned: racham)

References

Details

(Whiteboard: [PDT-])

If you start with a clean slate, say remove your .mozilla directory and have no
previous Navigator-version installed, there is no new Profile created. apprunner
comes up and works ... if you close it and start up again you have to walke
through the ProfileManager again and so on ...

nsProfile::CreateNewProfile needs to set sensible defaults if no
ProfileDirectory is given or no ProfileName is given. Instead it simply aborts
and no Profile at all is written.

ProfileMigration is searching for a default directory ... CreateNewProfile has
to do the same thing. It also has to set a default ProfileName if no one is
given like "Default" or something like that.
Assignee: selmer → racham
Bhuvan, what happened with this?  I thought we were already handling this case.
Status: NEW → ASSIGNED
Depends on: 12107
Target Milestone: M12
I know what happened here. Bug 7456 was used to track any misssing profile
directory cases. But the fix was to recreate the missing folder and fill it
with default contents. The fix did not recreate any of the parent folders.
The problem reported in this bug addresses that. So, this is another issue
of using CreateDirectory call which should be used with recursive creation
folders set to true, whereever appropriate. Making this bug dependent on Bug
#12107.
I just got bit by this and Andreas Otte suggested a work around which was:
apprunner -CreateProfile "ProfileName ProfileDirectory"
Dogfood Candidate
Summary: if you have no previous profile and nothing to migrate no profile is written → [DOGFOOD]if you have no previous profile and nothing to migrate no profile is written
Whiteboard: [PDT-]
Sounds like this would only impact QA so not a dogfood bug
I just nuked .mozilla and tried it again. Now it seem to work fine. The Profile
was created as it should. For me, this is fixed.
Grace,

Will you please check whether the bug still exists with current builds on all
platforms.

There are 2 things here.

First :
One if there is no 5.0 profile and nothing to migrate, profile wizard should
come up asking user to create a 5.0 profile.

Second : If user had profiles, but some how the directories are lost then
profile manager creates the folder for that profile with default contents
filled in. I think this is verified in 7456.

We can update the status of this bug depending on your feedback.

Thanks.
I can verify it for linux 2.2/glibc 2.1. It's just working fine. I'm just
updating my windows tree and do a clobber build. That will take some time
(vmware - win95 emulation). As sone as I have the results, I will update the
bug.
I have no mac to test it against. sorry.
The problem I had turned out to be a problem with our port. We were not able to
exit the GUI and restart it. We have since fixed it and this is working fine on
the Neutrino/Photon platform.
Jerry,
Would you mark this bug WORKSFORME?   My testing does not present this problem
here  so I need you to say it works with your testing on your platform-I can
then verify that it is no longer aproblem.

Thanks,
Grace
Well, I didn't report it, and I wasn't testing it on the platform that it was
reported on, so I'm not sure if I should do that.. Wouldn't that be left up
to the person who is assigned the bug?
As I said: I no longer see it on linux, where I initially reported it. My
windows build is not finished yet, but I don't think, I saw it there ever. But I
will check it.
On windows: Renaming Users50 to something else. I have to create Users50
manually, otherwise mozilla fails to startup while trying to read prefs.js
Andreas,
On Windows, try removing mozregistry.dat (in c:\windows) and the Users50
directory. Then launch mozilla and see if this problem persists.  You should
have to create a new profile this one time, but not again if you do nothing to
the file or directory.
Grace
No, this only happens when I "forget" to remove the registry file. When
mozregistry.dat is removed, the ProfileManager comes up as it should and creates
the Profile.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
The problem that andreas reported on windows is fixed. There is no need to
create User50 manually anymore. I checked in a fix to the bug 16414, which will
do the recursive creation of parent folders too. Resoving this bug by marking
it as a dup of Bug #16414.

*** This bug has been marked as a duplicate of 16414 ***
Status: RESOLVED → VERIFIED
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.