Build bustages at js/src/wasm/WasmOpIter.cpp when Gecko 64 merges to Beta on 2018-10-15

VERIFIED FIXED in Firefox 64

Status

()

defect
P3
normal
VERIFIED FIXED
10 months ago
10 months ago

People

(Reporter: apavel, Assigned: lth)

Tracking

Trunk
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(thunderbird_esr60 unaffected, geckoview62 unaffected, firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64+ verified)

Details

Attachments

(1 attachment)

[Tracking Requested - why for this release]:

Central as Beta simulation

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed,busted,exception,retry,usercancel,runnable&revision=c769757f218bacd64467e207450b1265cd52569d&selectedJob=201548432

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=201548432&repo=try&lineNumber=13948

[task 2018-09-25T22:45:45.568Z] 22:45:45     INFO -  /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/clang++ -o Unified_cpp_xpcom_components0.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/xpcom/components -I/builds/worker/workspace/build/src/obj-firefox/xpcom/components -I/builds/worker/workspace/build/src/obj-firefox/xpcom -I/builds/worker/workspace/build/src/xpcom/base -I/builds/worker/workspace/build/src/xpcom/build -I/builds/worker/workspace/build/src/xpcom/ds -I/builds/worker/workspace/build/src/chrome -I/builds/worker/workspace/build/src/modules/libjar -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Os -fno-omit-frame-pointer -funwind-tables -Werror -I/builds/worker/workspace/build/src/widget/gtk/compat-gtk3 -pthread -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/gtk-3.0/unix-print  -MD -MP -MF .deps/Unified_cpp_xpcom_components0.o.pp   /builds/worker/workspace/build/src/obj-firefox/xpcom/components/Unified_cpp_xpcom_components0.cpp
[task 2018-09-25T22:45:45.568Z] 22:45:45     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/xpcom/components'
[task 2018-09-25T22:45:45.568Z] 22:45:45     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/js/src'
[task 2018-09-25T22:45:45.568Z] 22:45:45     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/js/src'
[task 2018-09-25T22:45:45.570Z] 22:45:45     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/js/src'
[task 2018-09-25T22:45:45.570Z] 22:45:45     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/js/src'
[task 2018-09-25T22:45:46.458Z] 22:45:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/js/src'
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -  /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/clang++ -o Unified_cpp_js_src44.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DWASM_HUGE_MEMORY -DJS_CACHEIR_SPEW -DENABLE_SHARED_ARRAY_BUFFER -DJS_HAS_CTYPES -DFFI_BUILDING -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/js/src -I/builds/worker/workspace/build/src/obj-firefox/js/src -I/builds/worker/workspace/build/src/obj-firefox/js/src/ctypes/libffi/include -I/builds/worker/workspace/build/src/js/src/ctypes/libffi/src/x86 -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/js/src/js-confdefs.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-noexcept-type -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O3 -fno-omit-frame-pointer -funwind-tables -Werror -fno-strict-aliasing -Werror=format -Wno-shadow  -MD -MP -MF .deps/Unified_cpp_js_src44.o.pp   /builds/worker/workspace/build/src/obj-firefox/js/src/Unified_cpp_js_src44.cpp
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/js/src/Unified_cpp_js_src44.cpp:38:
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -  /builds/worker/workspace/build/src/js/src/wasm/WasmOpIter.cpp:248:19: error: 19 enumeration values not handled in switch: 'I32TruncSSatF32', 'I32TruncUSatF32', 'I32TruncSSatF64'... [-Werror,-Wswitch]
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -            switch (MiscOp(op.b1)) {
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -                    ^
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -  /builds/worker/workspace/build/src/js/src/wasm/WasmOpIter.cpp:29:13: error: enumeration value 'RefNull' not handled in switch [-Werror,-Wswitch]
[task 2018-09-25T22:45:46.466Z] 22:45:46     INFO -      switch (Op(op.b0)) {
[task 2018-09-25T22:45:46.467Z] 22:45:46     INFO -              ^
[task 2018-09-25T22:45:46.467Z] 22:45:46     INFO -  2 errors generated.
[task 2018-09-25T22:45:46.467Z] 22:45:46     INFO -  /builds/worker/workspace/build/src/config/rules.mk:1122: recipe for target 'Unified_cpp_js_src44.o' failed
[task 2018-09-25T22:45:46.467Z] 22:45:46     INFO -  make[4]: *** [Unified_cpp_js_src44.o] Error 1
[task 2018-09-25T22:45:46.467Z] 22:45:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/js/src'
[task 2018-09-25T22:45:46.467Z] 22:45:46     INFO -  make[4]: *** Waiting for unfinished jobs....
[task 2018-09-25T22:45:46.471Z] 22:45:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/xpcom/threads'
[task 2018-09-25T22:45:46.471Z] 22:45:46     INFO -  mkdir -p '.deps/'
[task 2018-09-25T22:45:46.471Z] 22:45:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/xpcom/threads'
[task 2018-09-25T22:45:46.471Z] 22:45:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/xpcom/threads'
[task 2018-09-25T22:45:46.471Z] 22:45:46     INFO -  xpcom/threads
[task 2018-09-25T22:45:46.471Z] 22:45:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/xpcom/threads'

This appears to be caused by bug 1493703. Lars, can you please take a look?
Flags: needinfo?(lhansen)
In my opinion -Werror is too aggressive for beta, given the number of things that get turned off, but sure, I can fix this...
Assignee: nobody → lhansen
Status: NEW → ASSIGNED
Flags: needinfo?(lhansen)
Priority: -- → P3
Comment on attachment 9012074 [details] [diff] [review]
bug1494134-classify-all-the-opcodes.patch

Review of attachment 9012074 [details] [diff] [review]:
-----------------------------------------------------------------

Nice!
Attachment #9012074 - Flags: review?(luke) → review+
(In reply to Lars T Hansen [:lth] from comment #1)
> In my opinion -Werror is too aggressive for beta, given the number of things
> that get turned off, but sure, I can fix this...

Thank you for looking into it.
https://hg.mozilla.org/mozilla-central/rev/355f1ffc8348
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.