Closed Bug 1494213 Opened 3 years ago Closed 3 years ago

mediaDevices.getUserMedia return LocalMediaStream instead of MediaStream

Categories

(Core :: WebRTC: Audio/Video, defect)

62 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1258143

People

(Reporter: henk, Unassigned, NeedInfo)

References

Details

(Whiteboard: [needinfo reporter 2018/09/30] )

Attachments

(1 file)

1.12 KB, video/vnd.dlna.mpeg-tts
Details
Attached video take-photo.component.ts
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Steps to reproduce:

I have angular code that was working fine with firefox 61. When upgraded to firefox 62.0.2 it failed.
Just run the attached angular component on FF 62.0.2.


Actual results:

The function navigator.mediaDevices.getUserMedia returns object of class LocalMediaStream.
The function window.URL.createObjectURL throws this exception:
ERROR Error: "Uncaught (in promise): TypeError: Argument 1 is not valid for any of the 1-argument overloads of URL.createObjectURL.



Expected results:

On Chrome, function navigator.mediaDevices.getUserMedia returns object of class MediaStream. That should happen. Was working with FF 61.0.2.
LocalMediaStream has been discontinued.
Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core
LocalMediaStream is a MediaStream.
Are you sure 61 was not returning a LocalMediaStream?

createObjectURL() is expected to throw an exception in 62 for any MediaStream.
See
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/62#Removals_3
61 should have been reporting a deprecation warning for this.
Blocks: 1454889
Flags: needinfo?(henk)
Whiteboard: [needinfo reporter 2018/09/30]
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1258143
You need to log in before you can comment on or make changes to this bug.