Closed Bug 1494279 Opened 4 years ago Closed 3 years ago

"Contact" form is not displayed on box.com while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 64
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-ads])

User Story

marketo.com

Attachments

(2 files)

Attached image Screenshot_2.png
[Environment:]
Browser / Version: Firefox Nightly 64.0a1 (2018-09-25) 
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to https://www.box.com/en-gb/quote 
    2. Observe the page.
       
[Expected Behavior:]
“Contact” form is not displayed.
 
[Actual Behavior:]
“Contact” form is not displayed.
The issue is related to `trackingprotection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://assets.adobedtm.com/1faedc806e38f986c51b7dc7c5cb49a40708fdca/satelliteLib-3f6f7433334fd8e721141048ec39aefe3aad2129.js” was blocked because content blocking is enabled.
The resource at “https://scripts.demandbase.com/lJdrm4D0.min.js” was blocked because content blocking is enabled.
The resource at “https://munchkin.marketo.net/munchkin.js” was blocked because content blocking is enabled.
The resource at “https://api.demandbase.com/api/v2/ip.json?key=3d2026d713e1b69a43e5b6ce5a6bc005&callback=optimizely_demandbase” was blocked because content blocking is enabled.
The resource at “https://app-sj16.marketo.com/js/forms2/js/forms2.min.js” was blocked because content blocking is enabled.
The resource at “https://js-agent.newrelic.com/nr-1071.min.js” was blocked because content blocking is enabled.

So below are the domains to test:
- ​assets.adobedtm.com
- ​scripts.demandbase.com
- ​api.demandbase.com
- ​munchkin.marketo.net
- ​app-sj16.marketo.com
- ​js-agent.newrelic.com

I opened the URL in a fresh browser profile (Firefox Nightly 64, uMatrix installed, normal mode) and loaded the page. The form is not displayed.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- boxcdn.net (including related domains)
- marketo.com (including related domains)
and the form is displayed.

The other resources didn't help. 

So in conclusion:
- marketo.com is in Advertising category = [tp-ads]
- boxcdn.net is not listed
User Story: (updated)
Whiteboard: [tp-ads]
Attached image uMatrixResults.png
Added uMatrix results.
Product: Tech Evangelism → Web Compatibility

This works for me now with basic (Standard) protection

It does not work with Strict protection.

I also don't see boxcdn.net blocked anymore.

I don't think this is our issue. This is legitimately a tracker and we are blocking it.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.