Closed Bug 1494285 Opened Last year Closed Last year

Rename nsDisplaySVGEffects and subclasses

Categories

(Core :: SVG, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

Details

Attachments

(3 files)

Having "SVG" in the name nsDisplaySVGEffects is misleading nowadays. The mask and filter subclasses can be created purely for CSS masks and filters.

While on the topic, nsDisplayMask and nsDisplayFilter sound like they apply a single mask/filter. It would be better if these names were pluralized.
Comment on attachment 9012386 [details]
Bug 1494285 p3. Rename nsDisplayFilter to nsDisplayFilters. r?miko

Miko Mynttinen [:miko] has approved the revision.
Attachment #9012386 - Flags: review+
Comment on attachment 9012380 [details]
Bug 1494285 p1. Rename nsDisplaySVGEffects to nsDisplayEffectsBase. r?miko

Miko Mynttinen [:miko] has approved the revision.
Attachment #9012380 - Flags: review+
Comment on attachment 9012385 [details]
Bug 1494285 p2. Rename nsDisplayMask to nsDisplayMasksAndClipPaths. r?miko

Miko Mynttinen [:miko] has approved the revision.
Attachment #9012385 - Flags: review+
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/115d5367d2f2
p1. Rename nsDisplaySVGEffects to nsDisplayEffectsBase. r=miko
https://hg.mozilla.org/integration/mozilla-inbound/rev/2933d542499d
p2. Rename nsDisplayMask to nsDisplayMasksAndClipPaths. r=miko
https://hg.mozilla.org/integration/mozilla-inbound/rev/b33c273fe7d5
p3. Rename nsDisplayFilter to nsDisplayFilters. r=miko
You need to log in before you can comment on or make changes to this bug.