Make mtransport API entirely async

RESOLVED FIXED in Firefox 65

Status

()

enhancement
P2
normal
RESOLVED FIXED
7 months ago
23 days ago

People

(Reporter: bwc, Assigned: bwc)

Tracking

(Blocks 1 bug)

60 Branch
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

7 months ago
There are a few places where the mtransport API has a function that returns stuff when called on STS (eg; GetDefaultCandidates). This will need to be refactored to be async, since we're going to be serving this API vie IPC.
(Assignee)

Comment 1

6 months ago
I think we'll end up using some cacheing for transport state, and keep MediaTransportHandler::GetState, but we need to make stats calls async, and also plumb a way for errors to get back in an async manner.
(Assignee)

Comment 2

6 months ago
I will also remove nsresult returns that don't actually do anything besides trigger some logging on the signaling side of things.
(Assignee)

Updated

5 months ago
No longer depends on: 1494311
(Assignee)

Updated

5 months ago
Blocks: 1507861
Blocks: socket-proc-webrtc
No longer blocks: socket-proc
(Assignee)

Updated

5 months ago
Duplicate of this bug: 1483276

Comment 16

5 months ago
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4185df9ce3e1
Part 1: Remove unused nsresult returns from MediaTransportHandler. r=mjf
https://hg.mozilla.org/integration/autoland/rev/ca59ca222bd5
Part 2: Make the internal PC stats API based on MozPromise. r=mjf,mayhemer
https://hg.mozilla.org/integration/autoland/rev/f28667d0d2cb
Part 3: Expose RLog stuff via MediaTransportHandler. r=mjf

Comment 17

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4185df9ce3e1
https://hg.mozilla.org/mozilla-central/rev/ca59ca222bd5
https://hg.mozilla.org/mozilla-central/rev/f28667d0d2cb
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Depends on: 1419325
Blocks: 1419325
No longer depends on: 1419325
You need to log in before you can comment on or make changes to this bug.