Closed Bug 1494387 Opened 1 year ago Closed 1 year ago

Update windows builders to user rust 1.30 beta

Categories

(Firefox Build System :: Toolchains, enhancement)

Unspecified
Windows
enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED DUPLICATE of bug 1500263
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: erahm, Assigned: chmanchester)

References

Details

Attachments

(1 file)

We landed a fix for Windows thread stack sizes in rust-lang/rust#52847. This should be in the currently available rust 1.30 beta release and we'd like to update at least our Windows build to use it.
Chris, can you help out with this?
Flags: needinfo?(cmanchester)
We can update the version we use in CI, but it might be a little trickier to get this in a release ahead of the 1.30 release... what are you proposing, exactly?
Flags: needinfo?(cmanchester)
(In reply to Chris Manchester (:chmanchester) from comment #2)
> We can update the version we use in CI, but it might be a little trickier to
> get this in a release ahead of the 1.30 release... what are you proposing,
> exactly?

We'd like to have mozilla-central based Firefox for Windows built in automation with rust version 1.30 (so m-c builds and nightly builds ideally).

We don't need to require 1.30 and we don't need it for other platforms. We don't need it backported to mozilla-beta or mozilla-release.
*we don't need to require it for local builds that is
I tested a patch to do this here: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=202285376&revision=bf361f198972f756d09a2ebe52584be4ebd3e225 which works fine and we can probably take, but if we don't want it to ride the trains we'll want to back it out from beta or before the next merge on October 22nd.
This updates our windows builders to use a version of rustc that includes
https://github.com/rust-lang/rust/pull/52847 We're not commiting to letting
this change ride the trains at this time.
Assignee: nobody → cmanchester
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/556b2f4cd653
Update windows builders to rustc 1.30 beta. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/556b2f4cd653
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
perf win:
== Change summary for alert #16476 (as of Thu, 04 Oct 2018 23:33:09 GMT) ==

Improvements:

  8%  Explicit Memory windows10-64-qr opt stylo           336,266,114.79 -> 308,720,503.20
  7%  Base Content Explicit windows10-64-qr opt stylo     12,839,765.33 -> 11,884,202.67

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=16476
Depends on: 1497133
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0b54085a89d4
Backed out changeset 556b2f4cd653 so it doesn't ride the trains.
The rest of the work related to this will be tracked by bug 1500263 where we'll update all of the builders.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1500263
The backout canceled all AWSY improvements we gained in comment 9:

== Change summary for alert #17005 (as of Mon, 22 Oct 2018 03:46:26 GMT) ==

Regressions:

  9%  Base Content Explicit windows10-64 opt stylo        11,447,637.33 -> 12,523,520.00
  8%  Base Content Explicit windows10-64-qr opt stylo     11,589,802.67 -> 12,546,389.33
  7%  Base Content Explicit windows10-64 pgo stylo        11,569,152.00 -> 12,400,298.67
  5%  Explicit Memory windows10-64-qr opt stylo           350,526,723.19 -> 368,935,029.35
  2%  Explicit Memory windows10-64 opt stylo              313,316,892.65 -> 320,433,660.78

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=17005
It also reduced build times:

== Change summary for alert #16966 (as of Thu, 18 Oct 2018 19:24:19 GMT) ==

Improvements:

  5%  build times windows2012-64 opt plain taskcluster-c4.4xlarge     2,372.56 -> 2,247.73

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=16966
You need to log in before you can comment on or make changes to this bug.