Save As dialog freezes when navigating to a folder

RESOLVED DUPLICATE of bug 1489785

Status

defect
--
critical
RESOLVED DUPLICATE of bug 1489785
7 months ago
7 months ago

People

(Reporter: nixon049, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180920135444

Steps to reproduce:

Thunderbird 60.0b11 (64-bit) is consistently freezing during file save operations on macOS Mojave. File save dialog becomes unresponsive after attempting to navigate to a specific folder. Buttons and macOS Touchbar do not respond to any mouse action. Remainder of the OS is unaffected.


Actual results:

Trying to save a file (either saving message as a file, or saving an attachment) initially allows user to interact with the save dialog window, but after one or two clicks to navigate to another folder, the UI becomes unresponsive. Thunderbird Save As window remains on top of all other windows in the system. Window does not respond to clicks, key presses, or macOS Touchbar button presses. Program must be force-quit to resolve. Other programs are unaffected. Tested with several different file attachments in several different email accounts, destination folder does not make a difference (same freezing behavior observed with multiple folders).


Expected results:

Expected that file save operation would work as normal.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1489785

Updated

7 months ago
Severity: normal → critical
Component: Untriaged → Message Reader UI
Keywords: hang

Updated

7 months ago
OS: Unspecified → Mac OS X
You need to log in before you can comment on or make changes to this bug.