Closed Bug 1494531 Opened Last year Closed Last year

Handle stores past the denseCapacity on dense arrays

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1494537

People

(Reporter: bas.schouten, Unassigned)

References

Details

This seems to be a major factor in our failures to generate specialized stubs in bug 1494504.
Summary: Handle Dense to Sparse array conversions → Handle stores past the denseCapacity on dense arrays
Kannan, can you refine this title or provide a better description of what is intended to be done in this bug because this bug subject makes no sense.

Is that for handling cases where we write at capacity+1 or for handling cases where we write at capacity+any?
Flags: needinfo?(kvijayan)
It's for `capacity + N` for any `N >= 1`.  This bug is a dup of bug 1494537, which is almost ready to land.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(kvijayan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1494537
You need to log in before you can comment on or make changes to this bug.