Intermittent Assertion failed: got false, expected true at: /builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6

RESOLVED FIXED in Firefox 64

Status

()

defect
P5
normal
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: intermittent-bug-filer, Assigned: luke)

Tracking

({assertion, intermittent-failure})

unspecified
mozilla64
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 fixed)

Details

Attachments

(1 attachment)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=201773147&repo=autoland

https://queue.taskcluster.net/v1/task/VPvtvErLQz-8WBUkClng5w/runs/1/artifacts/public/logs/live_backing.log

[task 2018-09-26T20:53:21.988Z] TEST-PASS | js/src/jit-test/tests/wasm/comments.js | Success (code 0, args "") [0.1 s]
[task 2018-09-26T20:53:21.989Z] {"action": "test_start", "jitflags": "", "pid": 111666, "source": "jittests", "test": "wasm/comments.js", "thread": "main", "time": 1537995201.855763}
[task 2018-09-26T20:53:21.989Z] {"action": "test_end", "extra": {"jitflags": "", "pid": 111666}, "jitflags": "", "message": "Success", "pid": 111666, "source": "jittests", "status": "PASS", "test": "wasm/comments.js", "thread": "main", "time": 1537995201.988889}
[task 2018-09-26T20:53:21.995Z] Error: Assertion failed: got false, expected true at:
[task 2018-09-26T20:53:21.996Z] testCached/<@/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:19:10
[task 2018-09-26T20:53:21.996Z] testCached@/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:29:6
[task 2018-09-26T20:53:21.996Z] @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:33:1
[task 2018-09-26T20:53:21.996Z] 
[task 2018-09-26T20:53:21.996Z] /builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6 Error: Assertion failed: got false, expected true
[task 2018-09-26T20:53:21.996Z] Stack:
[task 2018-09-26T20:53:21.996Z]   testCached@/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6
[task 2018-09-26T20:53:21.996Z]   @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:33:1
[task 2018-09-26T20:53:21.996Z] Exit code: 3
[task 2018-09-26T20:53:21.996Z] FAIL - wasm/caching.js
[task 2018-09-26T20:53:21.996Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/wasm/caching.js | /builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6 Error: Assertion failed: got false, expected true (code 3, args "--test-wasm-await-tier2") [0.1 s]
[task 2018-09-26T20:53:21.996Z] {"action": "test_start", "jitflags": "--test-wasm-await-tier2", "pid": 111665, "source": "jittests", "test": "wasm/caching.js", "thread": "main", "time": 1537995201.849381}
[task 2018-09-26T20:53:21.996Z] {"action": "test_end", "extra": {"jitflags": "--test-wasm-await-tier2", "pid": 111665}, "jitflags": "--test-wasm-await-tier2", "message": "/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6 Error: Assertion failed: got false, expected true", "pid": 111665, "source": "jittests", "status": "FAIL", "test": "wasm/caching.js", "thread": "main", "time": 1537995201.996048}
[task 2018-09-26T20:53:21.996Z] INFO exit-status     : 3
[task 2018-09-26T20:53:21.996Z] INFO timed-out       : False
[task 2018-09-26T20:53:21.996Z] INFO stdout          > Error: Assertion failed: got false, expected true at:
[task 2018-09-26T20:53:21.996Z] INFO stdout          > testCached/<@/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:19:10
[task 2018-09-26T20:53:21.996Z] INFO stdout          > testCached@/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:29:6
[task 2018-09-26T20:53:21.996Z] INFO stdout          > @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:33:1
[task 2018-09-26T20:53:21.997Z] INFO stdout          > 
[task 2018-09-26T20:53:21.997Z] INFO stderr         2> /builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6 Error: Assertion failed: got false, expected true
[task 2018-09-26T20:53:21.997Z] INFO stderr         2> Stack:
[task 2018-09-26T20:53:21.997Z] INFO stderr         2> testCached@/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:30:6
[task 2018-09-26T20:53:21.998Z] INFO stderr         2> @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/caching.js:33:1
[task 2018-09-26T20:53:22.011Z] TEST-PASS | js/src/jit-test/tests/wasm/caching.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off") [0.3 s]
[task 2018-09-26T20:53:22.012Z] {"action": "test_start", "jitflags": "--ion-eager --ion-offthread-compile=off", "pid": 111609, "source": "jittests", "test": "wasm/caching.js", "thread": "main", "time": 1537995201.67838}
[task 2018-09-26T20:53:22.012Z] {"action": "test_end", "extra": {"jitflags": "--ion-eager --ion-offthread-compile=off", "pid": 111609}, "jitflags": "--ion-eager --ion-offthread-compile=off", "message": "Success", "pid": 111609, "source": "jittests", "status": "PASS", "test": "wasm/caching.js", "thread": "main", "time": 1537995202.011832}
[task 2018-09-26T20:53:22.042Z] TEST-PASS | js/src/jit-test/tests/wasm/caching.js | Success (code 0, args "--no-wasm-ion") [0.2 s]
Hard to reproduce and verify, but I'm pretty sure this is it, for the reason now in the comment.
Assignee: nobody → luke
Attachment #9012634 - Flags: review?(lhansen)
Comment on attachment 9012634 [details] [diff] [review]
mark-tier-2-active-after-serialize

Review of attachment 9012634 [details] [diff] [review]:
-----------------------------------------------------------------

Has high plausibility.
Attachment #9012634 - Flags: review?(lhansen) → review+
Pushed by lwagner@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/909adfe5eaa7
Baldr: change order of setting tier-2 testing flag to fix testing race condition (r=lth)
https://hg.mozilla.org/mozilla-central/rev/909adfe5eaa7
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.