Closed Bug 1494595 Opened 1 year ago Closed 1 year ago

attachment icon not visible on a selected item with Linux High Contrast theme

Categories

(Thunderbird :: Theme, defect)

defect
Not set

Tracking

(thunderbird_esr60 fixed)

RESOLVED FIXED
Thunderbird 60.0
Tracking Status
thunderbird_esr60 --- fixed

People

(Reporter: aarnaud, Assigned: Paenglab)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180921231027

Steps to reproduce:

1) Choose the HighContrast theme on your GNU/Linux distribution. It's a built-in GTK3 theme. Here I'm on Debian Stretch (current stable, version 9.5) with GTK 3.22.11
3) Place the keyboard on a mail with an attachment 


Actual results:

The icon for the attachment since I've switched from Thunderbird 52 to Thunderbird 60.0. The issue does't appear on Thunderbird ESR 52 even if it was already in GTK3.


Expected results:

The icon for the attachment should be visible
See Also: → 1376756
This is a screenshot with an unselected mail where it's possible to see the icon.
Version: 54 Branch → 60
Flags: needinfo?(richard.marti)
This is a TB 60 only issue. From TB 61 the icons in trees can change their colour automatically. TB 60 needs a second icon for the selected state. On Windows default themes it's not needed as the colour doesn't change. But the high contrast themes and the Win7 Classic theme need this. I used the same icon Mac uses already but moved it to shared.

Try build to test on Windows: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=6232649a3bbc838f7827253a390998caea1cec42
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
Attachment #9013165 - Flags: review?(jorgk)
Attachment #9013165 - Flags: approval-comm-esr60?
A little late since I've just done the last push for TB 60.2.1. The try run is also not done yet. BTW, switching to Windows 10 "High Contrast White" shows the problem.
Comment on attachment 9013165 [details] [diff] [review]
HC-attachment.patch

Yes, this works after a restart of TB. It doesn't work when you switch to HC while TB is already running.

If bug 1481203 is ready before we build, I'll include this, otherwise I will have to wait until TB 60.3 later in October.
Attachment #9013165 - Flags: review?(jorgk)
Attachment #9013165 - Flags: review+
Attachment #9013165 - Flags: approval-comm-esr60?
Attachment #9013165 - Flags: approval-comm-esr60+
TB 60.2.1 ESR:
https://hg.mozilla.org/releases/comm-esr60/rev/5cdee4ae33c0868ae420a5a826c63b42d823c584
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 60.0
Component: Untriaged → Theme
You need to log in before you can comment on or make changes to this bug.