Perma [tier2] devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview

RESOLVED FIXED in Firefox 65

Status

defect
P5
normal
RESOLVED FIXED
9 months ago
8 months ago

People

(Reporter: intermittent-bug-filer, Assigned: davidwalsh)

Tracking

({intermittent-failure})

unspecified
Firefox 65

Firefox Tracking Flags

(firefox65 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment)

Reporter

Description

9 months ago
treeherder
Filed by: ebalazs [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=201930457&repo=mozilla-central

https://queue.taskcluster.net/v1/task/EUZQjdiaSnCJan0-L8JohA/runs/0/artifacts/public/logs/live_backing.log

Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
12:33:32     INFO - Buffered messages logged at 12:33:25
12:33:32     INFO - Finished waiting for state change: paused
12:33:32     INFO - Buffered messages logged at 12:33:26
12:33:32     INFO - Waiting for state change: selected source
12:33:32     INFO - Finished waiting for state change: selected source
12:33:32     INFO - Waiting for state change: 
12:33:32     INFO - Finished waiting for state change: 
12:33:32     INFO - Buffered messages logged at 12:33:27
12:33:32     INFO - Hovering at 10, 21
12:33:32     INFO - Buffered messages logged at 12:33:28
12:33:32     INFO - Hovering at 10, 21
12:33:32     INFO - Buffered messages logged at 12:33:29
12:33:32     INFO - Hovering at 10, 21
12:33:32     INFO - Buffered messages logged at 12:33:30
12:33:32     INFO - Hovering at 10, 21
12:33:32     INFO - Buffered messages logged at 12:33:31
12:33:32     INFO - Hovering at 10, 21
12:33:32     INFO - Buffered messages logged at 12:33:32
12:33:32     INFO - Hovering at 10, 21
12:33:32     INFO - Buffered messages finished
12:33:32     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview
12:33:32     INFO - Leaving test bound 
12:33:33     INFO - GECKO(2572) | ++DOMWINDOW == 24 (000001DFE05C5000) [pid = 4732] [serial = 276] [outer = 000001DFDF867C00]
12:33:46     INFO - GECKO(2572) | --DOMWINDOW == 23 (000001DFE05C7000) [pid = 4732] [serial = 267] [outer = 0000000000000000] [url = about:devtools-toolbox]
12:33:46     INFO - GECKO(2572) | --DOMWINDOW == 22 (000001DFE0815800) [pid = 4732] [serial = 269] [outer = 0000000000000000] [url = about:blank]
12:33:46     INFO - GECKO(2572) | --DOMWINDOW == 21 (000001DFE05C0800) [pid = 4732] [serial = 266] [outer = 0000000000000000] [url = about:blank]
12:33:46     INFO - GECKO(2572) | --DOMWINDOW == 20 (000001DFE081A000) [pid = 4732] [serial = 270] [outer = 0000000000000000] [url = about:blank]
12:33:46     INFO - Removing tab.
12:33:46     INFO - Waiting for event: 'TabClose' on [object XULElement].
12:33:47     INFO - Got event: 'TabClose' on [object XULElement].
12:33:47     INFO - Tab removed and finished closing
12:33:47     INFO - GECKO(2572) | --DOCSHELL 000001DFD69EF000 == 7 [pid = 4732] [id = {aac221cc-baeb-483d-a502-9e72b1f76ae8}]
12:33:47     INFO - GECKO(2572) | --DOCSHELL 000001DFE13D9800 == 6 [pid = 4732] [id = {b642ea1b-f7a9-4811-ac13-0a13a3b2b63b}]
12:33:47     INFO - GECKO(2572) | MEMORY STAT | vsize 2306MB | vsizeMaxContiguous 131875831MB | residentFast 546MB | heapAllocated 164MB
12:33:47     INFO - TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | took 78831ms
12:33:47     INFO - GECKO(2572) | ++DOCSHELL 000001ED5ADCF800 == 2 [pid = 7332] [id = {41c3235a-7712-46b6-bc0b-2972bd4b1f70}]
12:33:47     INFO - GECKO(2572) | ++DOMWINDOW == 3 (000001ED5B305400) [pid = 7332] [serial = 64] [outer = 0000000000000000]
12:33:47     INFO - GECKO(2572) | ++DOMWINDOW == 4 (000001ED5ADA9800) [pid = 7332] [serial = 65] [outer = 000001ED5B305400]
12:33:47     INFO - GECKO(2572) | ++DOMWINDOW == 5 (000001ED5ADAB800) [pid = 7332] [serial = 66] [outer = 000001ED5B305400]
ochameau: Could this be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1485676 ? Thanks!
Flags: needinfo?(poirot.alex)
This failure seems to occur only since a couple of builds. 
bug 1485676 reached mozilla-central branch quite a few changesets before without any failure until:
  https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=dt7%2Cccov&selectedJob=201802678&revision=7ac88abc3c57832e7e271dede934f8935c7f83a0

I requested some more runs on bug 1485676 to see if it reproduces back then:
  https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=dt7,ccov&selectedJob=201246505&revision=ea12f08bca89233f4f1037b6061a3877ab81d841

And also requested the build before 7ac88abc3c57832e7e271dede934f8935c7f83a0 to see if that's because of something from 7ac88abc3c57832e7e271dede934f8935c7f83a0 or before:
  https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=dt,ccov&selectedJob=201802678&revision=f8b2114ab5123475cebec470ead6136214c1d10c
Flags: needinfo?(poirot.alex)
See Also: → 1494140
Definitely not related to bug 1485676. As it doesn't reproduce on its related merge revision.
 
But it did not appeared on 7ac88abc3c57832e7e271dede934f8935c7f83a0 as it also reproduces on the build before:
  https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=dt7%2Cccov&revision=f8b2114ab5123475cebec470ead6136214c1d10c

I just requested some more runs on a couple of previous revisions.
Summary: Perma [tier2] devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview → Intermittent [tier2] devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview
It looks like it started on this pushlog:
  https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchStr=dt7%2Cccov&revision=f8b2114ab5123475cebec470ead6136214c1d10c
  Are you able to run tests on individial revisions from the integration branch it was merged from?
Comment hidden (Intermittent Failures Robot)
This bug has failed 40 times in the last 7 days. It only fails on ccov platforms, Windows10-64 and linux64 on debug build type.

Recent log:
https://treeherder.mozilla.org/logviewer.html#?job_id=203463569&repo=mozilla-central&lineNumber=5598

INFO - Buffered messages logged at 18:50:19
18:50:25     INFO - Finished waiting for state change: paused
18:50:25     INFO - Finished waiting for state change: paused
18:50:25     INFO - Waiting for state change: selected source
18:50:25     INFO - Finished waiting for state change: selected source
18:50:25     INFO - Waiting for state change: 
18:50:25     INFO - Finished waiting for state change: 
18:50:25     INFO - Buffered messages logged at 18:50:20
18:50:25     INFO - Hovering at 10, 21
18:50:25     INFO - Buffered messages logged at 18:50:21
18:50:25     INFO - Hovering at 10, 21
18:50:25     INFO - Buffered messages logged at 18:50:22
18:50:25     INFO - Hovering at 10, 21
18:50:25     INFO - Buffered messages logged at 18:50:23
18:50:25     INFO - Hovering at 10, 21
18:50:25     INFO - Buffered messages logged at 18:50:24
18:50:25     INFO - Hovering at 10, 21
18:50:25     INFO - Buffered messages logged at 18:50:25
18:50:25     INFO - Hovering at 10, 21
18:50:25     INFO - Buffered messages finished
18:50:25     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview
18:50:25     INFO - Leaving test bound 
18:50:26     INFO - GECKO(6568) | ++DOMWINDOW == 24 (000001DAB4233C00) [pid = 7992] [serial = 276] [outer = 000001DAB23E9A00]
18:50:40     INFO - GECKO(6568) | --DOMWINDOW == 23 (000001DAB29C5C00) [pid = 7992] [serial = 267] [outer = 0000000000000000] [url = about:devtools-toolbox]
18:50:40     INFO - GECKO(6568) | --DOMWINDOW == 22 (000001DAB29C8000) [pid = 7992] [serial = 266] [outer = 0000000000000000] [url = about:blank]
18:50:40     INFO - GECKO(6568) | --DOMWINDOW == 21 (000001DAB6B9A800) [pid = 7992] [serial = 269] [outer = 0000000000000000] [url = about:blank]
18:50:40     INFO - GECKO(6568) | --DOMWINDOW == 20 (000001DAB6B9F000) [pid = 7992] [serial = 270] [outer = 0000000000000000] [url = about:blank]
18:50:41     INFO - Removing tab.
18:50:41     INFO - Waiting for event: 'TabClose' on [object XULElement].
18:50:41     INFO - Got event: 'TabClose' on [object XULElement].
18:50:41     INFO - Tab removed and finished closing
18:50:41     INFO - GECKO(6568) | --DOCSHELL 000001DAB37C5800 == 7 [pid = 7992] [id = {b7e8cdaa-e594-4254-8be8-ccbeb6b59674}]
18:50:41     INFO - GECKO(6568) | --DOCSHELL 000001DAA8AF3800 == 6 [pid = 7992] [id = {09a48999-e2c5-4d72-9666-c36b3953c46c}]
18:50:41     INFO - GECKO(6568) | MEMORY STAT | vsize 2311MB | vsizeMaxContiguous 131519248MB | residentFast 551MB | heapAllocated 165MB
18:50:41     INFO - TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | took 81604ms
18:50:41     INFO - GECKO(6568) | ++DOCSHELL 000001A991872800 == 2 [pid = 2028] [id = {57ef383e-4193-49df-be91-37dab81db592}]
18:50:41     INFO - GECKO(6568) | ++DOMWINDOW == 3 (000001A998105000) [pid = 2028] [serial = 80] [outer = 0000000000000000]
18:50:41     INFO - GECKO(6568) | ++DOMWINDOW == 4 (000001A995AB0000) [pid = 2028] [serial = 81] [outer = 000001A998105000]
18:50:42     INFO - GECKO(6568) | ++DOMWINDOW == 5 (000001A997CAB400) [pid = 2028] [serial = 82] [outer = 000001A998105000]
18:50:42     INFO - checking window state
18:50:42     INFO - TEST-START | devtools/client/debugger/new/test/mochitest/browser_dbg-reload.js
18:50:42     INFO - GECKO(6568) | ++DOCSHELL 00000166EA0A3000 == 2 [pid = 5980] [id = {66dde691-0c71-4d5e-a31b-3ca7b412fa64}]
18:50:42     INFO - GECKO(6568) | ++DOMWINDOW == 3 (00000166EA0F1200) [pid = 5980] [serial = 90] [outer = 0000000000000000]
18:50:42     INFO - GECKO(6568) | ++DOMWINDOW == 4 (00000166EA0CB400) [pid = 5980] [serial = 91] [outer = 00000166EA0F1200]
18:50:43     INFO - GECKO(6568) | ++DOMWINDOW == 5 (00000166EA3B5000) [pid = 5980] [serial = 92] [outer = 00000166EA0F1200]
18:50:45     INFO - GECKO(6568) | ++DOCSHELL 000001DAB37C6800 == 7 [pid = 7992] [id = {95234eda-bc8e-475c-af6c-7a40a7f8be66}]
18:50:45     INFO - GECKO(6568) | ++DOMWINDOW == 21 (000001DAB354FC00) [pid = 7992] [serial = 277] [outer = 0000000000000000]
18:50:45     INFO - GECKO(6568) | ++DOMWINDOW == 22 (000001DAB29C9400) [pid = 7992] [serial = 278] [outer = 000001DAB354FC00]
18:50:45     INFO - GECKO(6568) | ++DOMWINDOW == 23 (000001DAB29CA800) [pid = 7992] [serial = 279] [outer = 000001DAB354FC00]
18:50:48     INFO - GECKO(6568) | ++DOCSHELL 000001DAA8AF8000 == 8 [pid = 7992] [id = {ff6c4fd3-c9d3-41ab-b392-e3dd501fe139}]
18:50:48     INFO - GECKO(6568) | ++DOMWINDOW == 24 (000001DAB3550E00) [pid = 7992] [serial = 280] [outer = 0000000000000000]
18:50:48     INFO - GECKO(6568) | ++DOMWINDOW == 25 (000001DAB6B9FC00) [pid = 7992] [serial = 281] [outer = 000001DAB3550E00]
18:50:51     INFO - GECKO(6568) | --DOMWINDOW == 4 (00000166EA0F1A00) [pid = 5980] [serial = 87] [outer = 0000000000000000] [url = about:blank]
18:50:51     INFO - GECKO(6568) | --DOCSHELL 00000166EA0A3800 == 1 [pid = 5980] [id = {ed5a93be-2371-447c-b5f2-9a5d55c02f45}]
18:50:52     INFO - GECKO(6568) | --DOMWINDOW == 1 (0000020CA700C200) [pid = 2988] [serial = 76] [outer = 0000000000000000] [url = http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/doc-react.html]
18:50:52     INFO - GECKO(6568) | --DOCSHELL 0000020CA0568000 == 0 [pid = 2988] [id = {46ce4dcf-8b46-4dee-81ab-e354bb9b15c2}]
18:50:55     INFO - GECKO(6568) | --DOMWINDOW == 3 (00000166EA0D3000) [pid = 5980] [serial = 89] [outer = 0000000000000000] [url = about:blank]
18:50:55     INFO - GECKO(6568) | --DOMWINDOW == 2 (00000166EA0CB400) [pid = 5980] [serial = 91] [outer = 0000000000000000] [url = about:blank]
18:50:56     INFO - GECKO(6568) | --DOMWINDOW == 0 (0000020CA69B4800) [pid = 2988] [serial = 78] [outer = 0000000000000000] [url = http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/doc-react.html]
18:50:57     INFO - GECKO(6568) | [ACTION] ADD_SOURCES  - {"type":"ADD_SOURCES","sources":[{"id":"server1.conn40.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","isPrettyPrinted":false,"isWasm":false,"sourceMapURL":null,"isBlackBoxed":false,"loadedState":"unloaded"}]}
18:50:58     INFO - GECKO(6568) | --DOMWINDOW == 4 (000001A998105400) [pid = 2028] [serial = 77] [outer = 0000000000000000] [url = about:blank]
18:50:58     INFO - GECKO(6568) | --DOCSHELL 000001A99186F800 == 1 [pid = 2028] [id = {44f84b8b-96ee-4f19-beef-f6730195e46e}]
18:50:58     INFO - GECKO(6568) | [ACTION] SET_WORKERS  - {"type":"SET_WORKERS","workers":[]}
18:50:58     INFO - GECKO(6568) | [ACTION] CONNECT  - {"type":"CONNECT","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/doc-reload.html","canRewind":false}
18:50:58     INFO - GECKO(6568) | [ACTION] PAUSE_ON_EXCEPTIONS [start] - {"type":"PAUSE_ON_EXCEPTIONS","shouldPauseOnExceptions":false,"shouldPauseOnCaughtExceptions":true,"seqId":"1","status":"start"}
18:50:58     INFO - GECKO(6568) | [ACTION] PAUSE_ON_EXCEPTIONS [done] - {"type":"PAUSE_ON_EXCEPTIONS","shouldPauseOnExceptions":false,"shouldPauseOnCaughtExceptions":true,"seqId":"1","status":"done","value":{"from":"server1.conn40.child1/context22","type":"paused","actor":"server1.conn40.child1/pause27","poppedFrames":[],"why":{"type":"interrupted"}}}
18:51:00     INFO - GECKO(6568) | [ACTION] SET_EXPANDED_STATE  - {"type":"SET_EXPANDED_STATE","expanded":{}}
18:51:01     INFO - GECKO(6568) | [ACTION] SET_ORIENTATION  - {"type":"SET_ORIENTATION","orientation":"horizontal"}
18:51:02     INFO - GECKO(6568) | --DOMWINDOW == 3 (000001A997CA9C00) [pid = 2028] [serial = 79] [outer = 0000000000000000] [url = about:blank]
18:51:02     INFO - GECKO(6568) | --DOMWINDOW == 2 (000001A995AB0000) [pid = 2028] [serial = 81] [outer = 0000000000000000] [url = about:blank]
18:51:02     INFO - GECKO(6568) | [ACTION] ADD_TAB  - {"type":"ADD_TAB","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"}
18:51:03     INFO - GECKO(6568) | [ACTION] SET_SELECTED_LOCATION  - {"type":"SET_SELECTED_LOCATION","source":{"id":"server1.conn40.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","sourceMapURL":null,"isBlackBoxed":false,"isPrettyPrinted":false,"isWasm":false,"contentType":"","loadedState":"unloaded","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"},"location":{"sourceId":"server1.conn40.child1/source26"}}
18:51:06     INFO - GECKO(6568) | [Parent 7992, Main Thread] WARNING: Please do not use mouseenter/leave events in chrome. They are slower than mouseover/out!: '!nsContentUtils::IsChromeDoc(d)', file z:/build/build/src/dom/events/EventListenerManager.cpp, line 379
18:51:06     INFO - GECKO(6568) | [Parent 7992, Main Thread] WARNING: Please do not use mouseenter/leave events in chrome. They are slower than mouseover/out!: '!nsContentUtils::IsChromeDoc(d)', file z:/build/build/src/dom/events/EventListenerManager.cpp, line 379
18:51:08     INFO - GECKO(6568) | [ACTION] LOAD_SOURCE_TEXT [start] - {"type":"LOAD_SOURCE_TEXT","sourceId":"server1.conn40.child1/source26","seqId":"2","status":"start"}
18:51:10     INFO - GECKO(6568) | [ACTION] LOAD_SOURCE_TEXT [done] - {"type":"LOAD_SOURCE_TEXT","sourceId":"server1.conn40.child1/source26","seqId":"2","status":"done","value":{"id":"server1.conn40.child1/source26","text":"","contentType":"application/x-javascript"}}
18:51:13     INFO - GECKO(6568) | [ACTION] SET_SYMBOLS [start] - {}
18:51:13     INFO - GECKO(6568) | [ACTION] OUT_OF_SCOPE_LOCATIONS  - {}
18:51:13     INFO - GECKO(6568) | [ACTION] IN_SCOPE_LINES  - {}
18:51:13     INFO - GECKO(6568) | [ACTION] SET_SYMBOLS [done] - {}
18:51:14     INFO - GECKO(6568) | [ACTION] SET_PAUSE_POINTS  - {}
18:51:14     INFO - GECKO(6568) | [ACTION] UPDATE_TAB  - {"type":"UPDATE_TAB","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"}
18:51:14     INFO - GECKO(6568) | [ACTION] SET_SOURCE_METADATA  - {"type":"SET_SOURCE_METADATA","sourceId":"server1.conn40.child1/source26","sourceMetaData":{}}
18:51:15     INFO - GECKO(6568) | [ACTION] ADD_BREAKPOINT [start] - {"type":"ADD_BREAKPOINT","breakpoint":{"condition":null,"disabled":false,"hidden":false,"loading":false,"astLocation":{"offset":{"sourceId":"server1.conn40.child1/source26","line":2}},"generatedLocation":{"sourceId":"server1.conn40.child1/source26","line":2},"location":{"sourceId":"server1.conn40.child1/source26","line":2}},"seqId":"4","status":"start"}
18:51:15     INFO - GECKO(6568) | [ACTION] ADD_BREAKPOINT [done] - {"type":"ADD_BREAKPOINT","breakpoint":{"condition":null,"disabled":false,"hidden":false,"loading":false,"astLocation":{"offset":{"sourceId":"server1.conn40.child1/source26","line":2}},"generatedLocation":{"sourceId":"server1.conn40.child1/source26","line":2},"location":{"sourceId":"server1.conn40.child1/source26","line":2}},"seqId":"4","status":"done","value":{"breakpoint":{"id":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs:2:","disabled":false,"hidden":false,"loading":false,"condition":null,"location":{"sourceId":"server1.conn40.child1/source26","line":2,"sourceUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"},"astLocation":{"name":"foo","offset":{"line":1}},"generatedLocation":{"sourceId":"server1.conn40.child1/source26","line":2,"sourceUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"},"text":"console.log(\"yo\")","originalText":"console.log(\"yo\")"},"previousLocation":null}}
18:51:16     INFO - GECKO(6568) | [ACTION] NAVIGATE  - {"type":"NAVIGATE","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/doc-reload.html"}
18:51:18     INFO - GECKO(6568) | ++DOMWINDOW == 3 (00000166EA0CF000) [pid = 5980] [serial = 93] [outer = 00000166EA0F1200]
18:51:19     INFO - GECKO(6568) | [ACTION] ADD_SOURCES  - {"type":"ADD_SOURCES","sources":[{"id":"server1.conn40.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","isPrettyPrinted":false,"isWasm":false,"sourceMapURL":null,"isBlackBoxed":false,"loadedState":"unloaded"}]}
18:51:19     INFO - GECKO(6568) | [ACTION] SET_SELECTED_LOCATION  - {"type":"SET_SELECTED_LOCATION","source":{"id":"server1.conn40.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","sourceMapURL":null,"isBlackBoxed":false,"isPrettyPrinted":false,"isWasm":false,"contentType":"","loadedState":"unloaded","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"},"location":{"sourceId":"server1.conn40.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"}}
18:51:19     INFO - GECKO(6568) | [ACTION] LOAD_SOURCE_TEXT [start] - {"type":"LOAD_SOURCE_TEXT","sourceId":"server1.conn40.child1/source26","seqId":"5","status":"start"}
18:51:22     INFO - GECKO(6568) | [ACTION] LOAD_SOURCE_TEXT [done] - {"type":"LOAD_SOURCE_TEXT","sourceId":"server1.conn40.child1/source26","seqId":"5","status":"done","value":{"id":"server1.conn40.child1/source26","text":"","contentType":"application/x-javascript"}}
18:51:24     INFO - GECKO(6568) | [ACTION] SET_SYMBOLS [start] - {}
18:51:24     INFO - GECKO(6568) | [ACTION] OUT_OF_SCOPE_LOCATIONS  - {}
18:51:24     INFO - GECKO(6568) | [ACTION] IN_SCOPE_LINES  - {}
18:51:24     INFO - GECKO(6568) | [Parent 7992, StreamTrans #790] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/modules/libjar/nsJARChannel.cpp, line 419
18:51:24     INFO - GECKO(6568) | [Parent 7992, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/modules/libjar/nsJARChannel.cpp, line 1127
18:51:24     INFO - GECKO(6568) | [ACTION] SET_SYMBOLS [done] - {}
18:51:24     INFO - GECKO(6568) | [ACTION] SET_PAUSE_POINTS  - {}
18:51:24     INFO - GECKO(6568) | [ACTION] UPDATE_TAB  - {"type":"UPDATE_TAB","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs"}
18:51:24     INFO - GECKO(6568) | [ACTION] SET_SOURCE_METADATA  - {"type":"SET_SOURCE_METADATA","sourceId":"server1.conn40.child1/source26","sourceMetaData":{}}
18:51:26     INFO - GECKO(6568) | [ACTION] SYNC_BREAKPOINT  - {"type":"SYNC_BREAKPOINT","breakpoint":{"id":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs:6:","condition":null,"disabled":false,"hidden":false,"loading":false,"astLocation":{"name":"foo","offset":{"line":1}},"generatedLocation":{"line":6,"sourceUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","sourceId":"server1.conn40.child1/source26"},"location":{"line":6,"sourceUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","sourceId":"server1.conn40.child1/source26"},"text":"console.log(\"YO\")","originalText":"console.log(\"YO\")"},"previousLocation":{"sourceUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/sjs_code_reload.sjs","line":2,"sourceId":"server1.conn40.child1/source26"}}
18:51:27     INFO - GECKO(6568) | ++DOMWINDOW == 26 (000001DAB29CD800) [pid = 7992] [serial = 282] [outer = 000001DAB354FC00]
18:51:31     INFO - GECKO(6568) | --DOMWINDOW == 2 (00000166EA3B5000) [pid = 5980] [serial = 92] [outer = 0000000000000000] [url = http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/reload/doc-reload.html]
18:51:31     INFO - GECKO(6568) | --DOCSHELL 000001DAB37C6800 == 7 [pid = 7992] [id = {95234eda-bc8e-475c-af6c-7a40a7f8be66}]
18:51:31     INFO - GECKO(6568) | --DOCSHELL 000001DAA8AF8000 == 6 [pid = 7992] [id = {ff6c4fd3-c9d3-41ab-b392-e3dd501fe139}]
18:51:31     INFO - GECKO(6568) | MEMORY STAT | vsize 2288MB | vsizeMaxContiguous 131519248MB | residentFast 509MB | heapAllocated 150MB
18:51:31     INFO - TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg-reload.js | took 49147ms
18:51:31     INFO - GECKO(6568) | ++DOCSHELL 00000166E3C71800 == 2 [pid = 5980] [id = {5da538da-7f7e-4b4d-83b1-9b569dbe2251}]
18:51:31     INFO - GECKO(6568) | ++DOMWINDOW == 3 (00000166EA374E00) [pid = 5980] [serial = 94] [outer = 0000000000000000]
18:51:31     INFO - GECKO(6568) | ++DOMWINDOW == 4 (00000166EA0CD000) [pid = 5980] [serial = 95] [outer = 00000166EA374E00]
18:51:31     INFO - GECKO(6568) | ++DOMWINDOW == 5 (00000166EA3B7800) [pid = 5980] [serial = 96] [outer = 00000166EA374E00]
18:51:31     INFO - checking window state 

pbro:
Flags: needinfo?(pbrosset)
QA Contact: pbrosset
Whiteboard: [stockwell needswork]
Transferring to David for further investigation. Thanks!
Flags: needinfo?(pbrosset) → needinfo?(dwalsh)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 10

9 months ago
Looking into this now!
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 12

8 months ago
This is still on my radar but with Jason gone and other urgent priorities I've not been able to jump on this yet.  Will very soon though.
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
davidwalsh: Hi, This became a perma failing:

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&resultStatus=success%2Cpending%2Crunning%2Ctestfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&searchStr=windows10-64-ccov%2Cdebug%2Cmochitests%2Cwith%2Ce10s%2Ctest-windows10-64-ccov%2Fdebug-mochitest-devtools-chrome-e10s-4%2Cm-e10s%28dt4%29&selectedJob=208305038
Summary: Intermittent [tier2] devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview → Perma [tier2] devtools/client/debugger/new/test/mochitest/browser_dbg-react-app.js | Uncaught exception - failed to preview
Assignee

Comment 16

8 months ago
I'll be on this ASAP this morning.
Flags: needinfo?(dwalsh)
Assignee

Comment 18

8 months ago
Adding skip-if=true because this test uses Preview which has issues on Windows testing.  Likewise tests also have this flag.  I will investigate this week why preview is so painful in Windows tests.
Attachment #9020899 - Flags: review+
Assignee

Updated

8 months ago
Keywords: checkin-needed

Comment 19

8 months ago
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b66b7e6fe25
Skip debugger's react test on Windows r=jlaster
Keywords: checkin-needed

Comment 20

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8b66b7e6fe25
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.