Closed Bug 1494672 Opened Last year Closed Last year

Regression: When you select a tag in the quick filter bar, that tag is no longer highlighted

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set

Tracking

(thunderbird_esr6062+ fixed, thunderbird63 fixed, thunderbird64 fixed)

RESOLVED FIXED
Thunderbird 64.0
Tracking Status
thunderbird_esr60 62+ fixed
thunderbird63 --- fixed
thunderbird64 --- fixed

People

(Reporter: david, Assigned: Paenglab)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180830143136

Steps to reproduce:

Thunderbird 60.0 (64-bit)
macOS version 10.13.6

1. Click the Tags button on the Quick Filter bar
2. Click on a tag to filter the list of items



Actual results:

Items are filtered, but the tag in the Quick Filter Bar does not change, so there is no way to know which tag is selected. 


Expected results:

When I click on a tag, that tag should be highlighted (outlined) so that I can tell which tags are currently selected. This is how it worked in previous releases. This is especially challenging when tags do not have a color assigned or several tags have the same color assigned.
Assignee: nobody → richard.marti
Attached patch bug1494672.patchSplinter Review
This makes also under all platforms the tag button appearance like the other QFP buttons.

The CSS code is needed to make the second toolbar not taller as without patch.
Attachment #9012685 - Flags: review?(jorgk)
The same for beta.
Attachment #9012687 - Flags: approval-comm-beta?
No Mac CSS changes here? This was reported for TB 60 ESR, so is there a patch for that?
Hmm, buttons highlight in TB 60 ESR on Windows. But this was reported for Mac. Also, what is the regressing bug?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
For Mac the addition of the toolbarbutton-1 class is enough.
Can't say which bug. Could be the QFB theming bug.
Patch for ESR60. No change in Linux messenger.css needed because toolkit's toolbarbutton.css is loaded through xul.css and not as document stylesheet.
Attachment #9012696 - Flags: approval-comm-esr60?
Well, on Windows 10 the buttons highlight in TB 60 and on trunk and I see no change with the patch. However, I noticed some issues:
- the highlight is one pixel to short compared to the "Any/All" box to the left
- the highlight, or shall I say, "black-light" is barely visible with the Dark theme, no change with the patch.

So questions:
- Is TB 60 affected?
- What changes do you expect on Windows/Linux? Are the CSS changes necessary?
- Maybe a Mac reviewer would be do a better job here?
Attached image with-patch.png
(In reply to Jorg K (GMT+2) from comment #8)
> Well, on Windows 10 the buttons highlight in TB 60 and on trunk and I see no
> change with the patch. However, I noticed some issues:
> - the highlight is one pixel to short compared to the "Any/All" box to the
> left
> - the highlight, or shall I say, "black-light" is barely visible with the
> Dark theme, no change with the patch.

Is the patch applied correctly? here the tag buttons have no more blueish but whitish (on dark theme) highlight and the height is the same as by the other buttons.

> So questions:
> - Is TB 60 affected?

Yes

> - What changes do you expect on Windows/Linux? Are the CSS changes necessary?

Windows with dark theme the selected button background color is almost not visible.

> - Maybe a Mac reviewer would be do a better job here?

Not needed as Windows is affected too with the wrong selected background color.
Comment on attachment 9012685 [details] [diff] [review]
bug1494672.patch

Sorry, I don't know what happened. Must not have applied the patch :-( - Not very good for the TB sheriff.
Attachment #9012685 - Flags: review?(jorgk) → review+
Attachment #9012687 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #9012696 - Flags: approval-comm-esr60? → approval-comm-esr60+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5664e476f06c
Fix tag selection in QFB by adding the toolbarbutton-1 class to the qfb-tag-button. r=jorgk DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Looking good in the ESR version on Windows, how about other platforms?
Checked on Mac and Linux. Both looking good.
You need to log in before you can comment on or make changes to this bug.