Closed Bug 149473 Opened 18 years ago Closed 18 years ago

Navigation toolbar not updated after viewing plugin in browser

Categories

(Core :: Plug-ins, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 82534

People

(Reporter: pkmed1aog001, Assigned: rubydoo123)

References

()

Details

(Whiteboard: [shockwave])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

After entering a Flash Movie, .PDF file, or Quick time movie in the address bar,
or by clicking a link that opens the movie in the main window, the movie works
fine, and the address bar shows the URL of the movie being played.

But when you press the back button, or load a different site, the URL of the
movie stays in the URL bar, and the state of the Back and Forward buttons also
doesn't properly update, so they are incorrectly enabled or disabled.  You might
be unable to press the Forward button and watch the movie again, and the back
button may be enabled when there is no site to return to.  The Go menu is also
affected the same as the Navigation Toolbar.

Also, when switching to a tab displaying the plugin, the address bar and
back/forward buttons are not updated then either.

Reproducible: Always
Steps to Reproduce:
1. Open a web page that links to a .swf or .pdf file, such as
http://newtown.hi-ho.ne.jp/raibo/raidersei/image/agency/cm
2. View a flash movie from that site by clicking on a link
3. Press the back button

Actual Results:  The url of the flash movie is displayed in the address bar, and
the forward button is disabled, the back button is enabled even if there is no
site to go back to.  The Go menu also has the same problem.

Expected Results:  The URL of the current page should be displayed instead of
the url of the flash movie.  The forward button should be enabled.
I am not able to reproduce this with a build from 6-6-2002 using the given 
testcase.

I tried it with several of the listed swf files, and everything seemed to work 
correctly.

marking bug as invalid.

anthonyd
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
Whiteboard: [shockwave]
reopening..I have seen this quite often. there's already a bug filed for this 
issue somewhere else (not under plugins). gotta find it...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
again, it's bug http://bugzilla.mozilla.org/show_bug.cgi?id=82534  :)

*** This bug has been marked as a duplicate of 82534 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Nope, in this bug the URL bar is still typable, but the URL of the plugin 
handled file stays in the bar until you hit the back button a few times.

The URL bar isn't locked, and you can still type in it.
http://bugzilla.mozilla.org/show_bug.cgi?id=142583
http://bugzilla.mozilla.org/show_bug.cgi?id=147710
http://bugzilla.mozilla.org/show_bug.cgi?id=131007

let's wait for 2 days..till that bug gets fixed. If this one doe snot get 
fixed... I will personally reopen this one. Thanks !
k am back, as promised. I just checked this out on trunk 0620 with the fix for 
bug 82534. BACK/FWD buttons work now and url bar updates as well. The only bad 
thing I noticed is while the flash miv eis actually loading...typing in the url 
bar does not have immediate effect, there is a second or 2 seconds lag. Peter, 
do u think I should file a  bug about that? Thx! 

The original issue is definitely fixed with 82534
You need to log in before you can comment on or make changes to this bug.