The sizing details of a flex-item are displayed without the user input when the cursor is placed on other elements in the page

RESOLVED WORKSFORME

Status

defect
P2
normal
RESOLVED WORKSFORME
8 months ago
8 months ago

People

(Reporter: paul.boiciuc, Unassigned)

Tracking

64 Branch
Unspecified
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20180927100044

STR:

1. Launch Firefox and navigate to a random page (e.g. nytimes.com)
2. Enable the element inspector.
3. Choose a Flex Container or Item.
4. Navigate to the Felexbox Inspector section and select the flex-item in order to view the sizing info.
5. Dismiss the sizing display by selecting the back arrow at the beginning of the flex-item label. 
4. Navigate through the page with the mouse pointer.
5. Observe the Flexbox Container/Item sizing details.

Actual result:

The sizing details of the flex-item that was previously viewed are displayed again, although this was dismissed by the user and did not enable them after. I could repro this on all platforms (Windows, Mac, Linux) with and/or without the Highlighter enabled. 
I have added a short video for a better understanding.

Expected result:

The sizing details display remains dismissed until the user chooses to enable it by selecting the flex-item in the Flexbox Inspector.
Reporter

Updated

8 months ago
Depends on: 1478396
Reporter

Updated

8 months ago
No longer depends on: 1478396
Blocks: 1478396
Priority: -- → P2
Reporter

Comment 1

8 months ago
I verified this issue using the latest Nightly ( Build ID: 20181009100040) on Windows 10, Ubuntu 18.04 and MacOS 10.13 and I was not able to reproduce it anymore. I'll close it as Resolved: Worksforme, and if the issue will resurface during feature testing, or later, the issue can be reopened.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.