many xpcom headers are not installed during a make install

RESOLVED FIXED in mozilla1.0.1

Status

P1
major
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: blizzard, Assigned: cls)

Tracking

Trunk
mozilla1.0.1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 8 obsolete attachments)

(Reporter)

Description

17 years ago
Lots of xpcom headers, including nsCOMPtr.h, aren't installed as part of make
install.  Patch to follow.
(Reporter)

Comment 1

17 years ago
Created attachment 86546 [details] [diff] [review]
patch that exports SDK_HEADERS
Comment on attachment 86546 [details] [diff] [review]
patch that exports SDK_HEADERS

r=cls
Attachment #86546 - Flags: review+

Updated

17 years ago
Attachment #86546 - Flags: approval+

Updated

17 years ago
Keywords: mozilla1.0.1+
Created attachment 86674 [details] [diff] [review]
install XPIDLSRCS & SDK_XPIDLSRCS too
Created attachment 86679 [details] [diff] [review]
Use $(idldir) for idls
Attachment #86674 - Attachment is obsolete: true
Created attachment 86691 [details] [diff] [review]
Fix nspr real_install issue when includedir  is specified
(Reporter)

Comment 6

17 years ago
Created attachment 86756 [details] [diff] [review]
patch that uses SYSINSTALL instead of INSTALL
(Reporter)

Comment 7

17 years ago
Created attachment 86759 [details] [diff] [review]
patch that includes all of the bits and pieces

Comment 8

17 years ago
*** Bug 149798 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Unfortunately the -8 release of the RPMs is missing nsBuildID.h 

Comment 10

17 years ago
I can verify that -8 doesn't include nsBuildID.h. Which I find to be required by
Galeon. I have also found that all the directories are missing from the list of
files created by rpm -ql mozilla-devel. So someone couldn't use rpm -qf
/usr/include/mozilla-1.0.0/expat , but could use rpm -qf
/usr/include/mozilla-1.0.0/expat/xmlparse.h   This has to do with a change in
the spec file between rc3 and 1.0. I would suggest this be fixed. I did a diff
of the files in mozilla-devel 1.0rc3 and 1.0.0-8 and found that the only file
missing is nsBuildID.h(well other than the directories I already mentioned). I
also found a number of .cfg files are missing ins mozilla-nspr-devel. In 1.0rc3
they were in mozilla-devel, but their section was moved to mozilla-nspr-devel in
1.0.0.

Comment 11

17 years ago
-9 fixes the lack of nsBuildID.h, but still has a problem with lack of .cfg
files in mozilla-nspr-devel.

Oddly enough Ximian seems to have rpms that have all the files from what I can
tell. Their source rpm seems to have a one of the older patches attached to this
bug report, or something similar to it. It is much shortly than the latest
patches. I didn't look into it with great detail, but they managed to compile
Galeon 1.2.5 against it. So either they have a good source rpm or they did a
hack  job on the rpms and released a broken source rpm.
Created attachment 86923 [details]
list of missing files in mozilla-devel-1.0.0-4.i386.rpm

I have tried to build skipstone with the mozilla-devel-1.0.0-4.rpm file and was
missing a couple of header files which I am attaching to this bug.

Comment 13

17 years ago
Adding /usr/lib/mozilla-%{version} to /etc/ld.so.conf post install and removing
it post uninstall is a must, since nss and nspr libraries were moved out of
/usr/lib and into /usr/lib/mozilla-%{version}. Evolution behaves badly without it.


Here are the commands to do it:

echo "/usr/lib/mozilla-%{version}" >> /etc/ld.so.conf

/bin/cat /etc/ld.so.conf | grep -v "/usr/lib/mozilla-%{version}" > /etc/ld.so.conf

Comment 14

17 years ago
I don't recommend using the commands I posted. They worked fine on the command
line, but I got an input/output error when uninstalling the rpm and it ate my
/etc/ld.so.conf. I have found RedHat has name evolution-1.0.5-2.4 which includes
a patch which makes the ld.so.conf entry unnecessary.
(Reporter)

Comment 15

17 years ago
Created attachment 86946 [details] [diff] [review]
final patch
Attachment #86546 - Attachment is obsolete: true
Attachment #86679 - Attachment is obsolete: true
Attachment #86691 - Attachment is obsolete: true
Attachment #86756 - Attachment is obsolete: true
Attachment #86759 - Attachment is obsolete: true
Attachment #86923 - Attachment is obsolete: true

Comment 17

17 years ago
Your final patch is identical to the one in mozilla-1.0.0-9 which is incomplete.
It still doesn't address the missing .cfg files. I know it might not directly
relate to this bug, but it is related.
The .cfg files are private NSPR cfg files that aren't meant to be installed on
the system.  The only reason they were installed into $(DIST) in the first place
was so that we could cross-compile.
 
Severity: normal → major
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.0.1
(Reporter)

Comment 19

17 years ago
Created attachment 87378 [details] [diff] [review]
more final patch

Fix problems with nsBuildID.h being regenerated during make install.
(Reporter)

Updated

17 years ago
Attachment #86946 - Attachment is obsolete: true
Comment on attachment 87378 [details] [diff] [review]
more final patch

r=cls
Attachment #87378 - Flags: review+
Patch has been checked in on the mozilla trunk, mozilla 1.0 branch & the nspr trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
adding branch resolution keyword.
Keywords: mozilla1.0.1+ → fixed1.0.1
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.