Update webrender to d7a6d081384ce0da9dd359b0cf4b9f758aab1b67

RESOLVED FIXED in Firefox 64

Status

()

enhancement
P3
normal
RESOLVED FIXED
7 months ago
12 days ago

People

(Reporter: darkspirit, Assigned: jrmuizel)

Tracking

(Blocks 2 bugs)

64 Branch
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

7 months ago
+++ This bug was initially created as a clone of Bug #1494206 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
(Reporter)

Updated

7 months ago
Blocks: 1493917
(Reporter)

Updated

7 months ago
Blocks: 1493327

Comment 3

7 months ago
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ab5269bd3c21
Update webrender to commit d7a6d081384ce0da9dd359b0cf4b9f758aab1b67
https://hg.mozilla.org/integration/mozilla-inbound/rev/f1dcdcc1674b
Re-generate FFI header
(Reporter)

Updated

7 months ago
Alias: wr-future-update
Assignee: nobody → jmuizelaar
Summary: Future webrender update bug → Update webrender to d7a6d081384ce0da9dd359b0cf4b9f758aab1b67

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ab5269bd3c21
https://hg.mozilla.org/mozilla-central/rev/f1dcdcc1674b
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
(Reporter)

Updated

7 months ago
Depends on: 1496019
Depends on: 1501111
(Reporter)

Updated

5 months ago
Depends on: 1509248
Depends on: 1503373

Updated

2 months ago
Depends on: 1527751
No longer depends on: 1527751
Regressions: 1527751
You need to log in before you can comment on or make changes to this bug.