Closed Bug 1494931 Opened Last year Closed Last year

Preferences and toggle button for enabling and disabling an extension broken

Categories

(Toolkit :: Add-ons Manager, defect)

62 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1464743

People

(Reporter: thomas.werner, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180920131237

Steps to reproduce:

1) Install an extension from AMO where you own the source code for development
2) Extension is working (after several restarts too)
3) Then debug the same extension from source code for development 
4) Everything is working Firefox uses local version/code not AMO version until you 
5) Quit and restart Firefox
5) Go to Add-ons Manager overview


Actual results:

* Preferences button and full title of extension from AMO is gone *
In previous versions of Firefox workaround was just to disable and re-enable extension, but seem not working anymore with 62 (maybe 60/61 i do not remember) because of:

* Pressing "Disable" the title and its icon will not be greyed out *
Seems that the title and its icon will just not be updated/toggled

* Pressing "Enable" after first "Disable" updates title and its icon but up to now its out of sync *


Expected results:

A restart of Firefox should clear debugged version and not broke AMO version or if so, "Enabled" and "Disable" should get back the right state of an extension.
Seems if the "Preferences" button is gone, the entire extension is broken.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1464743
You need to log in before you can comment on or make changes to this bug.