Closed Bug 1494939 Opened Last year Closed 5 months ago

extension `GL_ARB_gpu_shader5' unsupported in vertex shader

Categories

(Core :: Canvas: WebGL, defect, P3)

64 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1399501

People

(Reporter: sammmstr, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20180913222046

Steps to reproduce:

Using Firefox (version 59 through 64) on Linux with Mesa.  Visit one of these two example sites and observe console log and output.

- https://www.yanlinma.com/GeoSound2.github.io/
- https://codepen.io/Yakudoo/pen/YXxmYR

Please see the same issue marked as resolved, it is not resolved and easy to reproduce.
https://bugzilla.mozilla.org/show_bug.cgi?id=1310741
See also https://bugzilla.mozilla.org/show_bug.cgi?id=1449768


Actual results:

- Example sites do not render correctly.
- Console log shows error: extension 'GL_ARB_gpu_shaders5' unsupported.


Expected results:

Page should render correctly.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Attached file web_console.log
I was able to reproduce on Linux. The lion in the centre does not render. It does on Chrome without any warnings.

THREE.WebGLShader: gl.getShaderInfoLog() 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in vertex shader
THREE.WebGLShader: gl.getShaderInfoLog() 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in fragment shader
THREE.WebGLShader: Shader couldn't compile.
0:41(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:46(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:51(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:56(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:61(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:66(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:71(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:76(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
0:81(58): error: sampler arrays indexed with non-constant expressions are forbidden in GLSL 1.30 and later
Error: WebGL warning: linkProgram: Must have an compiled fragment shader attached. three.min.js:578:6
Error: WebGL warning: getUniformLocation: `program` must be linked.

I've attached the full log which also dumps the shader source.
I should also say that was from the second link (codepen).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jgilbert)
Priority: -- → P3
reproduced by simple example from three docs:
https://threejs.org/docs/#manual/en/introduction/Creating-a-scene

Debian/Firefox ESR 60.2.1esr (64-bit)

THREE.WebGLShader: gl.getShaderInfoLog() vertex 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in vertex shader
...
THREE.WebGLShader: gl.getShaderInfoLog() fragment 0:2(12): warning: extension `GL_ARB_gpu_shader5' unsupported in fragment shader
I confirm it's still there in Firefox Developer 63.0b14 (64-bit) -- it basically made me switch to Chrome for developing 3D web apps. Would be nice to fix it!
I can confirm that this bug is still present in Firefox Developer 64.0b5.

There are many examples linked above, but this one is mine: https://clayto.com/2017/03/meet-simpixel/

Here's a related issue: http://trac.webkit.org/changeset/220983/webkit. I get this warning whenever I compile a vertex shader with my laptop (Arch linux, integrated GPU, Firefox 65.0.2 (64-bit)).

Vertex source:


void main() {
  gl_Position = vec4(position, 0.0, 1.0);
}```

Translated shader source (from WEBGL_debug_shaders extension):
```#version 130
#extension GL_ARB_gpu_shader5 : enable
in vec2 webgl_fa67bdd9ecec0ae;
void main(){
(gl_Position = vec4(0.0, 0.0, 0.0, 0.0));
(gl_Position = vec4(webgl_fa67bdd9ecec0ae, 0.0, 1.0));
}```

On my Windows PC (same version of FF, GTX 770) the translated source has has no version or extension directives.
Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1399501
You need to log in before you can comment on or make changes to this bug.