Status

()

defect
RESOLVED DUPLICATE of bug 1447775
7 months ago
7 months ago

People

(Reporter: neclimdul, Unassigned)

Tracking

(Blocks 1 bug, {regression})

64 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Posted image Selection_222.jpg
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20180928100051

Steps to reproduce:

Start Firefox Nightly


Actual results:

The bottom of the tab section is transparent instead of the correct background color.


Expected results:

The entire top bar should be correctly colored.
(Reporter)

Comment 1

7 months ago
A couple of additional notes.

I haven't been paying close attention but I think it started when I updated yesterday morning, it wasn't fixed this morning so I'm filing the bug to make sure its visible.

It only seems to happen when first starting Firefox, it can happen on multiple windows, and moving the windows doesn't fix it but resizing it does and I don't think I've seen it come back.

Updated

7 months ago
Component: Untriaged → Theme
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

7 months ago
I've since found I'm actually able to recreate this by "maximizing" and then "un-maximizing" the window. Interestingly this reveals something that seems useful(at least to me). When maximized, tabs press 100% against the top and the tab area is slightly smaller. When you un-maximize, the section briefly remains smaller with the tabs against the top then it "pops" and the tabs drop down revealing the transparency. The transparent section seems to be the exact size of the expansion like this resizing doesn't trigger a corresponding redraw of the background.
Could this be caused by bug 1493145?
Flags: needinfo?(stransky)
(In reply to Dão Gottwald [::dao] from comment #3)
> Could this be caused by bug 1493145?

Yes, definitely. I suspect Gtk+ theme defines transparent color for GtkHeaderBar background. James, which theme do you use and which desktop environment do you run?
Flags: needinfo?(stransky) → needinfo?(neclimdul)
Component: Theme → Widget: Gtk
Product: Firefox → Core
(Reporter)

Comment 5

7 months ago
Default Firefox theme.
Ubuntu 18.04
Gnome 3 (3.28.2) 
Adwaita-dark Gnome theme.
Flags: needinfo?(neclimdul)
(In reply to James Gilliland from comment #5)
> Default Firefox theme.
> Ubuntu 18.04
> Gnome 3 (3.28.2) 
> Adwaita-dark Gnome theme.

Thanks. I'm unable to reproduce on Fedora 29 / Adwaita-dark theme. May be Ubuntu or Gnome 3.28 related.
btw. Do you have drag space enabled? (at Customize -> Drag space).
Flags: needinfo?(neclimdul)
Yes, I can reproduce that with drag space enabled - we need to extend the titlebar size when dragspace is on.
Flags: needinfo?(neclimdul)
Depends on: 1408360
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

7 months ago
Ah, yes drag space seems to be the key, good catch. Sorry I didn't get the notification quickly.

As noted, for what ever reason resizing fixes height. Not sure if that actually changes the height or what but its interesting.
(In reply to James Gilliland from comment #9)
> As noted, for what ever reason resizing fixes height. Not sure if that
> actually changes the height or what but its interesting.

That may be Bug 1447775
QA Contact: jmathies
QA Contact: jmathies
It's a variant of Bug 1447775 - when drag space is not covered by titlebar background until the window is resized. Closing as dupe.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1447775
You need to log in before you can comment on or make changes to this bug.