Autoselecting extension when saving not always correct

VERIFIED DUPLICATE of bug 120327

Status

VERIFIED DUPLICATE of bug 120327
17 years ago
14 years ago

People

(Reporter: andrixnet, Assigned: Matti)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Mozilla 1.0RC3 build 2002052306.

While browsing a ftp site, attempted to download a .tar.gz archive.
Mozilla's Save As dialog presented me with the name.tar.gz.tar and file type 
*.tar

Check URL above and try to download any of the 3 archives there.

Attempted the same download with Netscape 4.75 and I got a dialog asking what to 
do with Content-type application/x-tar, however, Netscape's Save As dialog 
presented the correct filename (name.tar.gz) whereas Mozilla's added 
automatically a .tar to it.

Expected behaviour:
Mozilla should not change the names of files it downloads and saves to disk. 
Possibly only one exception, for HTML files with the proper content-type and 
only if link does not feature a filename (ie save to disk http://www.mozilla.org 
into www.mozilla.org.htm)

Very bad example of current behaviour:
 link in page <a href="test.c">test.c</a>
 server returns Content-Type: text/plain
 Mozilla offers to save file test.c.txt

Forcing the user to check carefully the name chosen by Mozilla to save is an 
unwanted and unnecessary burden and leading to annoyance.
(either watch out for the names Mozilla wants to save, or be ready to rename 
files on disk after wandering why you don't find what you downloaded, or why it 
doesn't work.)
Reporter, please always search for existing bugs.

pi

*** This bug has been marked as a duplicate of 120327 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.