Can't delete specific search providers (probably langpack-related)

RESOLVED DUPLICATE of bug 1489820

Status

()

defect
RESOLVED DUPLICATE of bug 1489820
7 months ago
7 months ago

People

(Reporter: mozilla, Unassigned)

Tracking

62 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20100101

Steps to reproduce:

With an en-GB locale, created a fresh profile, and deleted all search engines from "One-Click Search Engines" in preferences, except Wikipedia (which I unticked from the list).


Actual results:

On restart, Amazon.co.uk and Chambers (UK) have reappeared at the bottom of autocomplete, and in "One-Click Search Engines" in preferences.


Expected results:

Unwanted search engines don't return from the dead.

Presumably this is a langpack-related bug. Examining (an unpacked copy of) search.json.mozlz4 from the profile after trying to delete them, there is nothing relating to either of those engines.

Strangely, Ebay UK is listed there though, which is a localised engine.

Updated

7 months ago
Component: Untriaged → Preferences

Updated

7 months ago
Component: Preferences → Search
What version of Firefox are you using? Your user agent says 60.0. Are you using the ESR?
(Reporter)

Comment 2

7 months ago
That's resistFingerprinting doing that. Unfortunately BZ doesn't provide an option for "don't attach UA" and doesn't have an "edit comment" feature either that I can see. I'd say that's Bad Design, but I digress :D

I am in fact on 62 (62.0.2), per the info I voluntarily added ;)
So we had a specific bug on this that we fixed in 62.0.2:

https://bugzilla.mozilla.org/show_bug.cgi?id=1489820
(Reporter)

Comment 4

7 months ago
Ah, yes, you're right, guess my system picked up the .2 release after I filed this bug, I must have been on .1 then. Thanks :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1489820
You need to log in before you can comment on or make changes to this bug.