Intermittent error: failed to run `rustc` to learn about target-specific information

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
9 months ago
7 months ago

People

(Reporter: intermittent-bug-filer, Assigned: kats)

Tracking

({intermittent-failure})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 fixed, firefox64 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

9 months ago
treeherder
Filed by: ccoroiu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=202449527&repo=mozilla-central

https://queue.taskcluster.net/v1/task/IBrXGUuPSRKCsGVUc9otYg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-09-30T10:34:09.007Z] 10:34:09     INFO -  MOZSEARCH: /builds/worker/workspace/build/src /builds/worker/workspace/build/src/obj-firefox/mozsearch_index/ /builds/worker/workspace/build/src/obj-firefox/
[task 2018-09-30T10:34:09.008Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-30T10:34:09.009Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.012Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o host_crc32.o -c  -DXP_UNIX -Os -DDEBUG=1 -I/builds/worker/workspace/build/src/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -MD -MP -MF .deps/host_crc32.o.pp -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr /builds/worker/workspace/build/src/modules/zlib/src/crc32.c
[task 2018-09-30T10:34:09.012Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.012Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.012Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.013Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-30T10:34:09.013Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-30T10:34:09.029Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-30T10:34:09.029Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/fdlibm/src'
[task 2018-09-30T10:34:09.047Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/js/src/rust'
[task 2018-09-30T10:34:09.048Z] 10:34:09     INFO -  js/src/rust/force-cargo-library-build
[task 2018-09-30T10:34:09.051Z] 10:34:09     INFO -  env    CARGO_TARGET_DIR=/builds/worker/workspace/build/src/obj-firefox/js/src/rust RUSTFLAGS='-C opt-level=2 -C debuginfo=2  -Zsave-analysis' RUSTC=/builds/worker/workspace/build/src/rustc/bin/rustc RUSTDOC=/builds/worker/workspace/build/src/rustc/bin/rustdoc RUSTFMT=/builds/worker/workspace/build/src/rustc/bin/rustfmt CC_x86_64_unknown_linux_gnu=" /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99" CXX_x86_64_unknown_linux_gnu=" /builds/worker/workspace/build/src/clang/bin/clang++" CFLAGS_x86_64_unknown_linux_gnu="-I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -I/builds/worker/workspace/build/src/js/src/rust -I/builds/worker/workspace/build/src/obj-firefox/js/src/rust -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -fPIC -include /builds/worker/workspace/build/src/obj-firefox/js/src/js-confdefs.h -DMOZILLA_CLIENT -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Xclang -add-plugin -Xclang mozsearch-index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox/mozsearch_index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox -O3 -fno-omit-frame-pointer -funwind-tables" CXXFLAGS_x86_64_unknown_linux_gnu="-I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -I/builds/worker/workspace/build/src/js/src/rust -I/builds/worker/workspace/build/src/obj-firefox/js/src/rust -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/js/src/js-confdefs.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-noexcept-type -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Xclang -add-plugin -Xclang mozsearch-index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox/mozsearch_index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox -O3 -fno-omit-frame-pointer -funwind-tables" AR_x86_64_unknown_linux_gnu="ar"  MOZ_SRC=/builds/worker/workspace/build/src MOZ_DIST=/builds/worker/workspace/build/src/obj-firefox/dist LIBCLANG_PATH="/builds/worker/workspace/build/src/clang/lib" CLANG_PATH="/builds/worker/workspace/build/src/clang/bin/clang" PKG_CONFIG_ALLOW_CROSS=1 RUST_BACKTRACE=full MOZ_TOPOBJDIR=/builds/worker/workspace/build/src/obj-firefox CARGO_INCREMENTAL=0 MOZ_CARGO_WRAP_LDFLAGS="-lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,--build-id=sha1 -Wl,-rpath-link,/builds/worker/workspace/build/src/obj-firefox/dist/bin -Wl,-rpath-link,/builds/worker/workspace/build/src/obj-firefox/dist/lib" MOZ_CARGO_WRAP_LD=" /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99" CARGO_TARGET_X86_64_UNKNOWN_LINUX_GNU_LINKER=/builds/worker/workspace/build/src/build/cargo-linker /builds/worker/workspace/build/src/rustc/bin/cargo rustc  --release --frozen --manifest-path /builds/worker/workspace/build/src/js/src/rust/Cargo.toml -vv --lib --target=x86_64-unknown-linux-gnu  --  -C lto
[task 2018-09-30T10:34:09.053Z] 10:34:09     INFO -  error: failed to run `rustc` to learn about target-specific information
[task 2018-09-30T10:34:09.053Z] 10:34:09     INFO -  Caused by:
[task 2018-09-30T10:34:09.054Z] 10:34:09     INFO -    process didn't exit successfully: `/builds/worker/workspace/build/src/rustc/bin/rustc - --crate-name ___ --print=file-names -C opt-level=2 -C debuginfo=2 -Zsave-analysis --target x86_64-unknown-linux-gnu --crate-type bin --crate-type rlib --crate-type dylib --crate-type cdylib --crate-type staticlib --crate-type proc-macro` (exit code: 1)
[task 2018-09-30T10:34:09.055Z] 10:34:09     INFO -  --- stderr
[task 2018-09-30T10:34:09.055Z] 10:34:09     INFO -  error: the option `Z` is only accepted on the nightly compiler
[task 2018-09-30T10:34:09.055Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/config/rules.mk:1048: recipe for target 'force-cargo-library-build' failed
[task 2018-09-30T10:34:09.056Z] 10:34:09     INFO -  make[4]: *** [force-cargo-library-build] Error 101
[task 2018-09-30T10:34:09.056Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/js/src/rust'
[task 2018-09-30T10:34:09.057Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/config/recurse.mk:74: recipe for target 'js/src/rust/target' failed
[task 2018-09-30T10:34:09.057Z] 10:34:09     INFO -  make[3]: *** [js/src/rust/target] Error 2
[task 2018-09-30T10:34:09.057Z] 10:34:09     INFO -  make[3]: *** Waiting for unfinished jobs....
[task 2018-09-30T10:34:09.057Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.057Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.057Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-30T10:34:09.060Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/clang/bin/clang++ -o appendable.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DU_COMMON_IMPLEMENTATION -DUCONFIG_NO_TRANSLITERATION -DUCONFIG_NO_REGULAR_EXPRESSIONS -DUCONFIG_NO_LEGACY_CONVERSION -DU_USING_ICU_NAMESPACE=0 -DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1 -DU_CHARSET_IS_UTF8 -DU_HAVE_NL_LANGINFO_CODESET=0 -DU_DEBUG=1 -I/builds/worker/workspace/build/src/config/external/icu/common -I/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common -I/builds/worker/workspace/build/src/intl/icu/source/i18n -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Xclang -add-plugin -Xclang mozsearch-index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox/mozsearch_index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox -Os -fno-omit-frame-pointer -funwind-tables -Wno-deprecated-declarations -Wno-type-limits -Wno-unused-but-set-variable -Wno-unused-function -Wno-sign-compare -Wno-maybe-uninitialized -frtti  -MD -MP -MF .deps/appendable.o.pp   /builds/worker/workspace/build/src/intl/icu/source/common/appendable.cpp
[task 2018-09-30T10:34:09.061Z] 10:34:09     INFO -  MOZSEARCH: /builds/worker/workspace/build/src /builds/worker/workspace/build/src/obj-firefox/mozsearch_index/ /builds/worker/workspace/build/src/obj-firefox/
[task 2018-09-30T10:34:09.061Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-30T10:34:09.062Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-30T10:34:09.062Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-30T10:34:09.069Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-30T10:34:09.069Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/config/external/icu/common'
[task 2018-09-30T10:34:09.110Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.110Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o host_gzclose.o -c  -DXP_UNIX -Os -DDEBUG=1 -I/builds/worker/workspace/build/src/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -MD -MP -MF .deps/host_gzclose.o.pp -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr /builds/worker/workspace/build/src/modules/zlib/src/gzclose.c
[task 2018-09-30T10:34:09.110Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.111Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.111Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.115Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.115Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.143Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/memory/replace/logalloc'
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/clang/bin/clang++ -o LogAlloc.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DMOZ_REPLACE_MALLOC_PREFIX=logalloc -DMOZ_NO_MOZALLOC -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/build/src/memory/replace/logalloc -I/builds/worker/workspace/build/src/obj-firefox/memory/replace/logalloc -I/builds/worker/workspace/build/src/memory/build -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Xclang -add-plugin -Xclang mozsearch-index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox/mozsearch_index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox -Os -fno-omit-frame-pointer -funwind-tables -Werror  -MD -MP -MF .deps/LogAlloc.o.pp   /builds/worker/workspace/build/src/memory/replace/logalloc/LogAlloc.cpp
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  MOZSEARCH: /builds/worker/workspace/build/src /builds/worker/workspace/build/src/obj-firefox/mozsearch_index/ /builds/worker/workspace/build/src/obj-firefox/
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/memory/replace/logalloc'
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.147Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/mozglue/misc'
[task 2018-09-30T10:34:09.167Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.168Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o crc32.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -I/builds/worker/workspace/build/src/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Xclang -add-plugin -Xclang mozsearch-index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox/mozsearch_index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox -Os -fno-omit-frame-pointer -funwind-tables -Werror -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments  -MD -MP -MF .deps/crc32.o.pp   /builds/worker/workspace/build/src/modules/zlib/src/crc32.c
[task 2018-09-30T10:34:09.168Z] 10:34:09     INFO -  MOZSEARCH: /builds/worker/workspace/build/src /builds/worker/workspace/build/src/obj-firefox/mozsearch_index/ /builds/worker/workspace/build/src/obj-firefox/
[task 2018-09-30T10:34:09.168Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.169Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.169Z] 10:34:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/modules/zlib/src'
[task 2018-09-30T10:34:09.175Z] 10:34:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr'
[task 2018-09-30T10:34:09.177Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o priometh.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -D_NSPR_BUILD_ -DHAVE_POINTER_LOCALTIME_R -DHAVE_FCNTL_FILE_LOCKING -D_GNU_SOURCE -DLINUX -D_PR_PTHREADS -I/builds/worker/workspace/build/src/config/external/nspr/pr -I/builds/worker/workspace/build/src/obj-firefox/config/external/nspr/pr -I/builds/worker/workspace/build/src/config/external/nspr -I/builds/worker/workspace/build/src/nsprpub/pr/include -I/builds/worker/workspace/build/src/nsprpub/pr/include/private -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Xclang -add-plugin -Xclang mozsearch-index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox/mozsearch_index -Xclang -plugin-arg-mozsearch-index -Xclang /builds/worker/workspace/build/src/obj-firefox -Os -fno-omit-frame-pointer -funwind-tables -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments  -MD -MP -MF .deps/priometh.o.pp   /builds/worker/workspace/build/src/nsprpub/pr/src/io/priometh.c
[task 2018-09-30T10:34:09.177Z] 10:34:09     INFO -  /builds/worker/workspace/build/src/nsprpub/pr/src/io/priometh.c:336:24: warning: comparison of integers of different signs: 'PROffset32' (aka 'int') and 'unsigned long' [-Wsign-compare]
[task 2018-09-30T10:34:09.178Z] 10:34:09     INFO -              (info.size < (sfd->file_offset + sfd->file_nbytes))) {
[task 2018-09-30T10:34:09.178Z] 10:34:09     INFO -               ~~~~~~~~~ ^  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[task 2018-09-30T10:34:09.178Z] 10:34:09     INFO -  1 warning generated.
It looks like the jsrust crate wasn't being built before and now is being built, as of bug 1490948. However, for some reason it's doing the build without the RUSTC_BOOTSTRAP=1 flag from the mozconfig [1]. It is picking up the RUSTFLAGS=-Zsave-analysis on the next line, and trying to use -Zsave-analysis without RUSTC_BOOTSTRAP=1 is failing. Benjamin, do you know where this env command is coming from and why it's missing the RUSTC_BOOTSTRAP=1 flag? For comparison see the previous passing build log [2] (grep for -Zsave-analysis and you'll see how the env includes RUSTC_BOOTSTRAP=1)

[1] https://searchfox.org/mozilla-central/rev/819cd31a93fd50b7167979607371878c4d6f18e8/browser/config/mozconfigs/linux64/debug-searchfox-clang#17
[2] https://taskcluster-artifacts.net/dMHYPVdKRhySnajH2Nd_4g/0/public/logs/live_backing.log
Blocks: 1490948
Flags: needinfo?(kats) → needinfo?(bbouvier)
Priority: P5 → P1
See Also: → 1495012
Comment hidden (Intermittent Failures Robot)
Never heard of this compilation option before, maybe Ted/Nathan who discussed it in bug 1495012 know a bit more?
Flags: needinfo?(ted)
Flags: needinfo?(nfroyd)
Flags: needinfo?(bbouvier)
MOZ_RUST_SIMD is only set for Gecko builds:

https://searchfox.org/mozilla-central/source/toolkit/moz.configure#653

I guess we should move that to someplace JS can see it, like build/moz.configure/rust.configure, so that the JS code being built will unlock Nightly features as well.
Flags: needinfo?(ted)
Flags: needinfo?(nfroyd)
I think this is separate from MOZ_RUST_SIMD; for the searchfox builds we're setting `export RUSTC_BOOTSTRAP=1` directly in the mozconfig so it should be applied to the environment for everything that gets built, no?

https://searchfox.org/mozilla-central/rev/819cd31a93fd50b7167979607371878c4d6f18e8/browser/config/mozconfigs/linux64/debug-searchfox-clang#17
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> I think this is separate from MOZ_RUST_SIMD; for the searchfox builds we're
> setting `export RUSTC_BOOTSTRAP=1` directly in the mozconfig so it should be
> applied to the environment for everything that gets built, no?
> 
> https://searchfox.org/mozilla-central/rev/
> 819cd31a93fd50b7167979607371878c4d6f18e8/browser/config/mozconfigs/linux64/
> debug-searchfox-clang#17

Indeed, I missed that part, thanks for pointing it out.

It's not clear to me how the export for RUSTFLAGS is making its way into the construction of the `cargo` command, but the RUSTC_BOOTSTRAP export does not also filter down into the invocation of the `cargo` command.  Does cargo scrub the environment somehow?...but then why would it scrub RUSTC_BOOTSTRAP in this case but not in our "normal" usage?
Oh, maybe the RUSTC_BOOTSTRAP from the mozconfig *never* propagates into the cargo command invocation, but this was masked by the fact that all other crates use the MOZ_RUST_SIMD thing? Note in particular that the previous passing log [1] has this command:

env   RUSTC_BOOTSTRAP=1  CARGO_TARGET_DIR=/builds/worker/workspace/build/src/obj-firefox/toolkit/library RUSTFLAGS='-C opt-level=2 -C debuginfo=2  -Zsave-analysis' RUSTC= ...

If the RUSTC_BOOTSTRAP=1 was just in the environment from the mozconfig, it wouldn't get printed here as part of the env command. The fact that it's getting printed here means it's coming from the rust_unlock_unstable at [2]. So maybe we should modify that rust_unlock_unstable setter to also propagate it from the environment if it's present?

[1] https://taskcluster-artifacts.net/dMHYPVdKRhySnajH2Nd_4g/0/public/logs/live_backing.log
[2] https://searchfox.org/mozilla-central/rev/819cd31a93fd50b7167979607371878c4d6f18e8/config/rules.mk#957
Presumably the RUSTFLAGS is getting propagated down via [1], so maybe another option is to do the same for RUSTC_BOOTSTRAP?

[1] https://searchfox.org/mozilla-central/rev/819cd31a93fd50b7167979607371878c4d6f18e8/build/moz.configure/toolchain.configure#1574
Assignee: nobody → kats
Attachment #9013314 - Flags: review?(nfroyd)
FWIW, this failure is basically the same as bug 1495012. See bug 1495012 comment 6 for an explanation.
Here's a green try push with regular builds I did to make sure the patch didn't break non-searchfox builds: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=7b4adaad8da22acf1a0f82ecd05c713a2c244e37
(In reply to Ted Mielczarek [:ted] [:ted.mielczarek] from comment #12)
> FWIW, this failure is basically the same as bug 1495012. See bug 1495012
> comment 6 for an explanation.

With respect to this, the "use nightly" solution is less desirable for searchfox since we're planning on having the code indexing also index the rust stdlib and it would be good to have that stdlib be the version of rust we're using in production (i.e. stable, not nightly). But if you *really* want we could use nightly... it's what I had originally planned on doing (see bug 1432475 comment 9 onwards for more context).
Comment on attachment 9013314 [details] [diff] [review]
Propagate RUSTC_BOOTSTRAP from the environment

Review of attachment 9013314 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/moz.configure/toolchain.configure
@@ +1579,5 @@
>  
> +option(env='RUSTC_BOOTSTRAP',
> +       nargs=1,
> +       help='Rust bootstrap override')
> +set_config('RUSTC_BOOTSTRAP', depends('RUSTC_BOOTSTRAP')(lambda flags: flags))

I think the better way to do this is to make --enable-rust-simd (which is already turned on for automation builds) a js_option, which should turn on RUSTC_BOOTSTRAP for JS crates as well as Gecko ones.  Please try that instead?
Attachment #9013314 - Flags: review?(nfroyd)
That ran into a configure error, but I don't know how to resolve it. Any help would be appreciated.
Oh, maybe I need to move it into the root moz.configure instead of the one in toolkit/. That seems to help locally.

Try with that: https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a93b6f54054121d6592a908c77e834e242d714b
Posted patch Make it a js_option (obsolete) — Splinter Review
Attachment #9013314 - Attachment is obsolete: true
Attachment #9013456 - Flags: review?(nfroyd)
Comment on attachment 9013456 [details] [diff] [review]
Make it a js_option

Review of attachment 9013456 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with this code in build/moz.configure/rust.configure instead of the toplevel moz.configure, please.  Thanks!
Attachment #9013456 - Flags: review?(nfroyd) → review+
Sorry for the runaround here. :(
(In reply to Nathan Froyd [:froydnj] from comment #20)
> r=me with this code in build/moz.configure/rust.configure instead of the
> toplevel moz.configure, please.  Thanks!

Kicked off a try push with that just to make sure: https://treeherder.mozilla.org/#/jobs?repo=try&bugfiler=&group_state=expanded&revision=161c9c6385173e7e64face222a7c6d892fd18c2e

(In reply to Nathan Froyd [:froydnj] from comment #21)
> Sorry for the runaround here. :(

No worries, thanks for the quick reviews!

Comment 23

9 months ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/11df51f97f13
Make enable-rust-simd a JS option so JS crates get built with the RUSTC_BOOTSTRAP=1 flag in automation. r=froydnj
(In reply to Nathan Froyd [:froydnj] from comment #15)
> Comment on attachment 9013314 [details] [diff] [review]
> Propagate RUSTC_BOOTSTRAP from the environment
> 
> Review of attachment 9013314 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: build/moz.configure/toolchain.configure
> @@ +1579,5 @@
> >  
> > +option(env='RUSTC_BOOTSTRAP',
> > +       nargs=1,
> > +       help='Rust bootstrap override')
> > +set_config('RUSTC_BOOTSTRAP', depends('RUSTC_BOOTSTRAP')(lambda flags: flags))
> 
> I think the better way to do this is to make --enable-rust-simd (which is
> already turned on for automation builds) a js_option, which should turn on
> RUSTC_BOOTSTRAP for JS crates as well as Gecko ones.  Please try that
> instead?

Huh, I beg to differ. We should use RUSTC_BOOTSTRAP less, not more. searchfox is a corner case that may want to use everywhere, but it should do so by setting it globally through the environment.

Comment 26

9 months ago
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b4331c9d829
Backed out changeset 11df51f97f13 for artifact build bustage
Flags: needinfo?(kats)
Do you prefer the first patch I wrote? (attachment 9013314 [details] [diff] [review])
Flags: needinfo?(mh+mozilla)
Setting it globally on the task would be better.
Flags: needinfo?(mh+mozilla)
Also FWIW the long term plan here for searchfox is to actually have a wrapper around rustc based on [1] that lets us get the save-analysis data from the stable compiler without having to use the bootstrap hack. I haven't figured out the build system well enough to attempt that yet.

[1] https://github.com/nrc/rls-rustc
(In reply to Mike Hommey [:glandium] from comment #28)
> Setting it globally on the task would be better.

I'm not sure what that means exactly. How do you set something globally for a task if not via the mozconfig (which apparently doesn't work anyway)?
Thanks, I'll try that!
(In reply to Mike Hommey [:glandium] from comment #24)
> (In reply to Nathan Froyd [:froydnj] from comment #15)
> > ::: build/moz.configure/toolchain.configure
> > @@ +1579,5 @@
> > >  
> > > +option(env='RUSTC_BOOTSTRAP',
> > > +       nargs=1,
> > > +       help='Rust bootstrap override')
> > > +set_config('RUSTC_BOOTSTRAP', depends('RUSTC_BOOTSTRAP')(lambda flags: flags))
> > 
> > I think the better way to do this is to make --enable-rust-simd (which is
> > already turned on for automation builds) a js_option, which should turn on
> > RUSTC_BOOTSTRAP for JS crates as well as Gecko ones.  Please try that
> > instead?
> 
> Huh, I beg to differ. We should use RUSTC_BOOTSTRAP less, not more.
> searchfox is a corner case that may want to use everywhere, but it should do
> so by setting it globally through the environment.

I thought the idea behind --enable-rust-simd is that we *don't* have to interact with RUSTC_BOOTSTRAP directly, since we are going behind rustc's back, in a sense.  --enable-rust-simd is there to keep RUSTC_BOOTSTRAP down somewhere where we invoke rustc, so that if we get a different interface for turning on Nightly features, we can use that instead.

--enable-rust-simd's usage has mutated a bit now that coverage (and searchfox) rely on -Z options, but I think the original idea is sound.
(In reply to Nathan Froyd [:froydnj] from comment #33)
> --enable-rust-simd's usage has mutated a bit now that coverage (and
> searchfox) rely on -Z options, but I think the original idea is sound.

But at the same time it feels hacky to be relying on a SIMD flag for getting access to -Zsave-analysis, which has nothing to do with SIMD. It would be good to explicitly have the searchfox task opt in to RUSTC_BOOTSTRAP so that if, for example, the SIMD code became available without RUSTC_BOOTSTRAP, we wouldn't just remove that rustc_unlock_unstable bit and break everything else.

Try push with glandium's suggestion: https://treeherder.mozilla.org/#/jobs?repo=try&revision=237670bfc51ef98648d21f9b34a981276f79ebeb
The original idea for --enable-rust-simd was to unlock usage of simd for encode-rs. It's never meant to be an unlock-all-unstable-features-everwhere thing, nor should it be. And since it's so tempting to abuse it, I'm more and more feeling like I should really finish that patch that I have to actually makes it unlock usage of simd for encode-rs.
Comment on attachment 9013583 [details] [diff] [review]
Move RUSTC_BOOTSTRAP to a place where it actually does something!

Review of attachment 9013583 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9013583 - Flags: review?(nfroyd) → review+

Comment 39

9 months ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3eb35625a84f
Set RUSTC_BOOTSTRAP in the taskcluster task definition instead of the mozconfig. r=froydnj

Comment 40

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3eb35625a84f
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.