Closed Bug 1495310 Opened 1 year ago Closed 1 year ago

Perma tp6_google [taskcluster:error] Task aborted - max run time exceeded when Gecko 64 merges to Beta on 2018-10-15

Categories

(Testing :: Talos, enhancement)

enhancement
Not set

Tracking

(geckoview62 unaffected, firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64+ disabled, firefox65 disabled)

VERIFIED FIXED
mozilla65
Tracking Status
geckoview62 --- unaffected
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 + disabled
firefox65 --- disabled

People

(Reporter: apavel, Assigned: aryx)

References

Details

Attachments

(1 file)

there are a few differences here:
1) firefox is started with this commandline: C:\Users\task_1538308922\build\application\firefox\firefox -wait-for-browser -no-deelevate -profile c:\users\task_1538308922\appdata\local\temp\tmp4gjopz\profile
* but on beta today we don't have -wait-for-browser and we don't have -no-deelevate, these are new features on trunk- maybe they are not supported on beta
2) 15:19:47     INFO -  PID 3288 | 1538320787056	addons.xpi-utils	WARN	Add-on pageloader@mozilla.org is not correctly signed.
15:19:47     INFO -  PID 3288 | 1538320787059	addons.xpi-utils	WARN	Add-on talos-powers@mozilla.org is not correctly signed.
* I know we have changed addons quite a bit on trunk- maybe those models will not work on beta, and it looks to be identified by the two above bugs.

I assume talos isn't the only thing broken- I assume all of talos will be broken by these changes.
Flags: needinfo?(jmaher)
Do the changes from bug 1488554 assume the launcher process is always enabled?
Duplicate of this bug: 1496774
(In reply to Julien Cristau [:jcristau] from comment #2)
> Do the changes from bug 1488554 assume the launcher process is always
> enabled?


Only 8461e2f532ed makes that assumption, mainly because AIUI Talos currently does not have the ability to run different tests depending on build configuration, which needs to happen when the launcher process is turned on.

See also bug 1494698.
Oh, and wait-for-browser and no-deelevate do not affect Firefox when the launcher process is disabled.
First merge of central to beta repository is on Monday (2018-10-15). Please decide how to proceed.
Flags: needinfo?(aklotz)
Backing out of 8461e2f532ed as we merge to Beta should have sufficed. Can I get some confirmation here?
Flags: needinfo?(aklotz) → needinfo?(aryx.bugmail)
The launcher only affects xperf, not tp6. I suspect a different cause.
Flags: needinfo?(aklotz)
aswan, could this have something to do with the pageloader changes?
Flags: needinfo?(aswan)
Possibly.  The signing errors Joel mentioned in comment 1 certainly look like a problem.  But I'm not sure how this works at all, we don't allow unsigned extensions at all on beta but a bunch of Talos tests use unsigned extensions...  Joel, I vaguely remember that we talked about this a few weeks ago but I've already forgotten the resolution.
Flags: needinfo?(aswan) → needinfo?(jmaher)
this is windows tp6 specifically, this isn't linux tp6 or osx tp6.  So in this case I would say that the pageloader changes are ok unless there is specific windows code.

One thing that tp6 does is: MOZ_DISABLE_NONLOCAL_CONNECTIONS=0, and I believe that needs to be MOZ_DISABLE_NONLOCAL_CONNECTIONS=1 for unsigned extensions.  Why would this work on linux/osx?
Flags: needinfo?(jmaher)
:aryx if you can push to try with raptor tp6 running that might be a solution here:
https://searchfox.org/mozilla-central/source/taskcluster/ci/test/raptor.yml#35

we could then turn off talos tp6 and just use raptor.  We are waiting for geckoProfile support before doing this on trunk, this should happen by the end of the month, so why not take something that runs reliably and use it instead.
Flags: needinfo?(aryx.bugmail)
What's needed to have raptor run on Try without |mach fuzzy|?

https://searchfox.org/mozilla-central/source/taskcluster/ci/test/raptor.yml#35 has it set for try
It belongs to raptor-firefox: https://searchfox.org/mozilla-central/source/taskcluster/ci/test/test-sets.yml#82
That should run for e.g. linx64/opt: https://searchfox.org/mozilla-central/source/taskcluster/ci/test/test-platforms.yml#44

Is anything in taskcluster/taskgraph/ different for raptor which would explain the difference? Thank you.
Flags: needinfo?(aryx.bugmail)
Flags: needinfo?(jmaher)
I am not aware of anything that would cause the difference.  Could we try a push with ./mach try fuzzy and see?  Also if it thinks that it is 'mozilla-beta' the jobs wouldn't run.
Flags: needinfo?(jmaher)
I did an add new job- want to turn tp6 off for talos on beta and on for raptor on beta?
Flags: needinfo?(aryx.bugmail)
It's your domain. Fine for me.
Flags: needinfo?(aryx.bugmail)
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/208695a01a3b
Enable Raptor Firefox tp6 and disable Talos tp6, both on beta r=jmaher
https://hg.mozilla.org/mozilla-central/rev/208695a01a3b
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Do we need to do something on Beta still for this or was your push today meant to resolve this?
Assignee: nobody → aryx.bugmail
Flags: needinfo?(aryx.bugmail)
Let's keep this closed, getting raptor tp6 working/signed in bug 1501040 sounds easier and more future-proof.
Flags: needinfo?(aryx.bugmail)
Verified that T-e10s(tp6) doesn't run on beta.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.