Closed Bug 1495478 Opened Last year Closed Last year

Intermittent /builds/worker/workspace/build/src/dom/media/webrtc/MediaTrackConstraints.cpp:484:3: error: use of undeclared identifier 'LogConstraints'

Categories

(Core :: WebRTC: Audio/Video, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jib)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: nerli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=202618300&repo=autoland

https://queue.taskcluster.net/v1/task/b46GCYsTRsmzqQ163fNsXA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-10-01T14:42:41.335Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dom/media/webrtc/Unified_cpp_dom_media_webrtc0.cpp:20:
[task 2018-10-01T14:42:41.335Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/dom/media/webrtc/MediaTrackConstraints.cpp:15:
[task 2018-10-01T14:42:41.336Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/MediaManager.h:33:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/media/MediaChild.h:10:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/dom/ContentChild.h:12:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/dom/ContentBridgeParent.h:10:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders/mozilla/dom/PContentBridgeParent.h:9:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders/mozilla/dom/PContentBridge.h:11:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/ipc/IPCMessageUtils.h:11:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_message_utils.h:15:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/ipc/chromium/src/base/string_util.h:106:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/ipc/chromium/src/base/string_util_win.h:25:55: warning: all paths through this function will call itself [-Winfinite-recursion]
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  inline int strcasecmp(const char* s1, const char* s2) {
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -                                                        ^
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/ipc/chromium/src/base/string_util_win.h:29:70: warning: all paths through this function will call itself [-Winfinite-recursion]
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  inline int strncasecmp(const char* s1, const char* s2, size_t count) {
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -                                                                       ^
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dom/media/webrtc/Unified_cpp_dom_media_webrtc0.cpp:20:
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/dom/media/webrtc/MediaTrackConstraints.cpp:484:3: error: use of undeclared identifier 'LogConstraints'
[task 2018-10-01T14:42:41.340Z] 14:42:41     INFO -    LogConstraints(c);
[task 2018-10-01T14:42:41.341Z] 14:42:41     INFO -    ^
[task 2018-10-01T14:42:41.341Z] 14:42:41     INFO -  2 warnings and 1 error generated.
[task 2018-10-01T14:42:41.341Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/config/rules.mk:1129: recipe for target 'Unified_cpp_dom_media_webrtc0.o' failed
[task 2018-10-01T14:42:41.341Z] 14:42:41     INFO -  make[4]: *** [Unified_cpp_dom_media_webrtc0.o] Error 1
[task 2018-10-01T14:42:41.341Z] 14:42:41     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/dom/media/webrtc'
[task 2018-10-01T14:42:41.342Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/config/recurse.mk:74: recipe for target 'dom/media/webrtc/target' failed
[task 2018-10-01T14:42:41.342Z] 14:42:41     INFO -  make[3]: *** [dom/media/webrtc/target] Error 2
[task 2018-10-01T14:42:41.342Z] 14:42:41     INFO -  make[3]: *** Waiting for unfinished jobs....
[task 2018-10-01T14:42:41.342Z] 14:42:41     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/dom/xbl'
[task 2018-10-01T14:42:41.343Z] 14:42:41     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/dom/xbl'
[task 2018-10-01T14:42:41.343Z] 14:42:41     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/dom/xbl'
[task 2018-10-01T14:42:41.343Z] 14:42:41     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/dom/xbl'
[task 2018-10-01T14:42:41.458Z] 14:42:41     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/dom/workers'
[task 2018-10-01T14:42:41.458Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/x86_64-w64-mingw32-clang++ -mwindows -o Unified_cpp_dom_workers1.o -c  -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -DDEBUG=1 -DWIN32_LEAN_AND_MEAN -D_WIN32 -DWIN32 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DOS_WIN=1 -D_UNICODE -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DUNICODE -D_WINDOWS -D_SECURE_ATL -DENABLE_WASM_GC -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/dom/workers -I/builds/worker/workspace/build/src/obj-firefox/dom/workers -I/builds/worker/workspace/build/src/caps -I/builds/worker/workspace/build/src/dom/base -I/builds/worker/workspace/build/src/dom/bindings -I/builds/worker/workspace/build/src/dom/system -I/builds/worker/workspace/build/src/js/xpconnect/loader -I/builds/worker/workspace/build/src/netwerk/base -I/builds/worker/workspace/build/src/xpcom/build -I/builds/worker/workspace/build/src/xpcom/threads -I/builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -I/builds/worker/workspace/build/src/ipc/chromium/src -I/builds/worker/workspace/build/src/ipc/glue -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Wstring-conversion -Wtautological-overlap-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=return-std-move -Wno-error=atomic-alignment -Wno-unknown-pragmas -Wno-unused-function -Wno-conversion-null -Wno-switch -Wno-enum-compare -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-sized-deallocation -fms-extensions -fno-exceptions -fno-strict-aliasing -mms-bitfields -Wno-incompatible-ms-struct -fno-rtti -ffunction-sections -fdata-sections -Wa,-mbig-obj -fno-exceptions -fno-math-errno -pipe -g -fno-omit-frame-pointer -funwind-tables -Wno-error=shadow  -MD -MP -MF .deps/Unified_cpp_dom_workers1.o.pp   /builds/worker/workspace/build/src/obj-firefox/dom/workers/Unified_cpp_dom_workers1.cpp
[task 2018-10-01T14:42:41.458Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dom/workers/Unified_cpp_dom_workers1.cpp:2:
[task 2018-10-01T14:42:41.458Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/dom/workers/WorkerLoadInfo.cpp:10:
[task 2018-10-01T14:42:41.458Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/mozilla/dom/TabChild.h:11:
[task 2018-10-01T14:42:41.458Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders/mozilla/dom/PBrowserChild.h:9:
[task 2018-10-01T14:42:41.459Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders/mozilla/dom/PBrowser.h:11:
[task 2018-10-01T14:42:41.459Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/obj-firefox/dist/include/ipc/IPCMessageUtils.h:11:
[task 2018-10-01T14:42:41.459Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_message_utils.h:15:
[task 2018-10-01T14:42:41.459Z] 14:42:41     INFO -  In file included from /builds/worker/workspace/build/src/ipc/chromium/src/base/string_util.h:106:
[task 2018-10-01T14:42:41.463Z] 14:42:41     INFO -  /builds/worker/workspace/build/src/ipc/chromium/src/base/string_util_win.h:25:55: warning: all paths through this function will call itself [-Winfinite-recursion]
[task 2018-10-01T14:42:41.463Z] 14:42:41     INFO -  inline int strcasecmp(const char* s1, const char* s2) {
Blocks: 1494498
Flags: needinfo?(tom)
Is this an intermittent or a perma-fail?

I've reproduced it every time I've tried (working off that autoland commit anyway) and am trying to figure out a fix for it.
tjr: it seems to be a perma-fail
Okay, now I understand the problem. This breaks --disable-webrtc (which MinGW is the only build to set currently.)

I'm not sure what the preferred way to fix this so I'm going to bounce this back to :jib
Assignee: nobody → jib
Flags: needinfo?(tom) → needinfo?(jib)
Flags: needinfo?(jib)
The fail was caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1494498#c4 .
Wasn`t sure how soon will be a fix for the issue so I`ve backed out that push
Comment on attachment 9013508 [details]
Bug 1495478 - Move LogConstraints() to class MediaConstraintsHelper and add logging of missing constraints (rollup includes backed-out bug 1494498) r?pehrsons

Andreas Pehrson [:pehrsons] has approved the revision.
Attachment #9013508 - Flags: review+
Pushed by jbruaroey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fb7f5d71b31a
Move LogConstraints() to class MediaConstraintsHelper and add logging of missing constraints (rollup includes backed-out bug 1494498) r=pehrsons
Attachment #9013508 - Attachment description: Bug 1495478 - Move LogConstraints() to class MediaConstraintsHelper to compile with --disable-webrtc. r?pehrsons → Bug 1495478 - Move LogConstraints() to class MediaConstraintsHelper and add logging of missing constraints (rollup includes backed-out bug 1494498) r?pehrsons
https://hg.mozilla.org/mozilla-central/rev/fb7f5d71b31a
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.