location.replace causes page-reload

VERIFIED INVALID

Status

()

Core
JavaScript Engine
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Christoph, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I found in the description by selfhtml.teamone.de that 

location.replace( 'myfile.htm' )

should replace the entry in the history but currently it causes a reload of the page

Comment 1

16 years ago
location.replace replaces what ever document it's referring to with the document
from the given URL. Clicking back doesn't get you back to the replaced page,
that's what "selfhtml" is referring to. This behaviour is intended.
(Reporter)

Comment 2

16 years ago
I see, was my fault
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
Marking Verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.