Closed Bug 1495715 Opened Last year Closed 8 months ago

Intermittent devtools/client/webconsole/test/mochitest/browser_jsterm_await_paused.js | Test timed out -

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox65 fixed, firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell needswork])

Attachments

(1 file)

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=202839241&repo=autoland

https://queue.taskcluster.net/v1/task/QbwPUbgjTjqpKOZnZTlzFw/runs/0/artifacts/public/logs/live_backing.log

[task 2018-10-02T10:38:55.864Z] 10:38:55     INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_await_paused.js | The output contains the the expected messages, in the expected order - 
[task 2018-10-02T10:38:55.865Z] 10:38:55     INFO - Adding a new tab with URL: data:text/html;charset=utf-8,Web Console test top-level await when debugger paused
[task 2018-10-02T10:38:55.866Z] 10:38:55     INFO - Buffered messages logged at 10:38:14
[task 2018-10-02T10:38:55.869Z] 10:38:55     INFO - Tab added and finished loading
[task 2018-10-02T10:38:55.869Z] 10:38:55     INFO - Opening the toolbox
[task 2018-10-02T10:38:55.871Z] 10:38:55     INFO - Toolbox opened and focused
[task 2018-10-02T10:38:55.873Z] 10:38:55     INFO - Buffered messages logged at 10:38:15
[task 2018-10-02T10:38:55.874Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.876Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.877Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.878Z] 10:38:55     INFO - Waiting for state change: paused
[task 2018-10-02T10:38:55.879Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.882Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.882Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.883Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.884Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.885Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.886Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.887Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.888Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.888Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.889Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.890Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.891Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.892Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.893Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.893Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.894Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.895Z] 10:38:55     INFO - Buffered messages logged at 10:38:16
[task 2018-10-02T10:38:55.896Z] 10:38:55     INFO - Finished waiting for state change: paused
[task 2018-10-02T10:38:55.897Z] 10:38:55     INFO - Finished waiting for state change: paused
[task 2018-10-02T10:38:55.898Z] 10:38:55     INFO - Waiting for state change: selected source
[task 2018-10-02T10:38:55.898Z] 10:38:55     INFO - Finished waiting for state change: selected source
[task 2018-10-02T10:38:55.899Z] 10:38:55     INFO - Resuming from 4
[task 2018-10-02T10:38:55.900Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.901Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.902Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.902Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.903Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.904Z] 10:38:55     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2018-10-02T10:38:55.905Z] 10:38:55     INFO - Buffered messages logged at 10:38:17
[task 2018-10-02T10:38:55.906Z] 10:38:55     INFO - Console message: [JavaScript Error: "ReferenceError: foo is not defined" {file: "debugger eval code" line: 3}]
[task 2018-10-02T10:38:55.906Z] 10:38:55     INFO - @debugger eval code:3:34
[task 2018-10-02T10:38:55.907Z] 10:38:55     INFO - setTimeout handler*@debugger eval code:3:5
[task 2018-10-02T10:38:55.908Z] 10:38:55     INFO - @debugger eval code:2:16
[task 2018-10-02T10:38:55.908Z] 10:38:55     INFO - async*@debugger eval code:1:2
[task 2018-10-02T10:38:55.909Z] 10:38:55     INFO - getEvalResult@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole/eval-with-debugger.js:134:18
[task 2018-10-02T10:38:55.909Z] 10:38:55     INFO - exports.evalWithDebugger@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole/eval-with-debugger.js:105:18
[task 2018-10-02T10:38:55.910Z] 10:38:55     INFO - evaluateJS@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole.js:1032:22
[task 2018-10-02T10:38:55.911Z] 10:38:55     INFO - evaluateJSAsync@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole.js:952:22
[task 2018-10-02T10:38:55.911Z] 10:38:55     INFO - onPacket@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:1313:15
[task 2018-10-02T10:38:55.912Z] 10:38:55     INFO - receiveMessage@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:66:5
[task 2018-10-02T10:38:55.913Z] 10:38:55     INFO - MessageListener.receiveMessage*_addListener@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:40:5
[task 2018-10-02T10:38:55.913Z] 10:38:55     INFO - ready@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:57:5
[task 2018-10-02T10:38:55.914Z] 10:38:55     INFO - _onConnection@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:892:5
[task 2018-10-02T10:38:55.915Z] 10:38:55     INFO - connectToParent@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:313:12
[task 2018-10-02T10:38:55.915Z] 10:38:55     INFO - onConnect</<@resource://devtools/server/startup/frame.js:50:22
[task 2018-10-02T10:38:55.916Z] 10:38:55     INFO - onConnect<@resource://devtools/server/startup/frame.js:49:7
[task 2018-10-02T10:38:55.917Z] 10:38:55     INFO - exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
[task 2018-10-02T10:38:55.917Z] 10:38:55     INFO - MessageListener.receiveMessage*@resource://devtools/server/startup/frame.js:72:5
[task 2018-10-02T10:38:55.918Z] 10:38:55     INFO - @resource://devtools/server/startup/frame.js:19:4
[task 2018-10-02T10:38:55.919Z] 10:38:55     INFO - 
[task 2018-10-02T10:38:55.920Z] 10:38:55     INFO - Buffered messages finished
[task 2018-10-02T10:38:55.920Z] 10:38:55     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_jsterm_await_paused.js | Test timed out - 
[task 2018-10-02T10:38:55.921Z] 10:38:55     INFO - Removing tab.
[task 2018-10-02T10:38:55.922Z] 10:38:55     INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2018-10-02T10:38:55.923Z] 10:38:55     INFO - Got event: 'TabClose' on [object XULElement].
[task 2018-10-02T10:38:55.924Z] 10:38:55     INFO - Tab removed and finished closing
[task 2018-10-02T10:38:56.143Z] 10:38:56     INFO - Removing tab.
[task 2018-10-02T10:38:56.144Z] 10:38:56     INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2018-10-02T10:38:56.162Z] 10:38:56     INFO - Got event: 'TabClose' on [object XULElement].
[task 2018-10-02T10:38:56.174Z] 10:38:56     INFO - Tab removed and finished closing
[task 2018-10-02T10:38:56.211Z] 10:38:56     INFO - GECKO(2556) | MEMORY STAT | vsize 784MB | residentFast 376MB | heapAllocated 140MB
[task 2018-10-02T10:38:56.217Z] 10:38:56     INFO - TEST-OK | devtools/client/webconsole/test/mochitest/browser_jsterm_await_paused.js | took 45949ms
Duplicate of this bug: 1506526

In the last 7 days, there have been 34 failures.

The failures are on linux32 and linux64.
Affected build types: opt and pgo.

An example of a recent log file:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=221502718&repo=mozilla-inbound&lineNumber=3906

And the relevant part of the log:
[task 2019-01-12T15:46:23.425Z] 15:46:23 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_jsterm_await_paused.js | The output contains the the expected messages, in the expected order -
[task 2019-01-12T15:46:23.426Z] 15:46:23 INFO - Adding a new tab with URL: data:text/html;charset=utf-8,Web Console test top-level await when debugger paused
[task 2019-01-12T15:46:23.428Z] 15:46:23 INFO - Tab added and finished loading
[task 2019-01-12T15:46:23.429Z] 15:46:23 INFO - Opening the toolbox
[task 2019-01-12T15:46:23.430Z] 15:46:23 INFO - Buffered messages logged at 15:45:42
[task 2019-01-12T15:46:23.434Z] 15:46:23 INFO - Toolbox opened and focused
[task 2019-01-12T15:46:23.436Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.437Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.439Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.451Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.454Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.455Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: version." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.459Z] 15:46:23 INFO - Buffered messages logged at 15:45:43
[task 2019-01-12T15:46:23.461Z] 15:46:23 INFO - Waiting for state change: paused
[task 2019-01-12T15:46:23.463Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.465Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.466Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.475Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.476Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.478Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.479Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.481Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.483Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.484Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.487Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.488Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.489Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.492Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.494Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.495Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.497Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.499Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.501Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.503Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.505Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.507Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.510Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.512Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.513Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.515Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.520Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.521Z] 15:46:23 INFO - Buffered messages logged at 15:45:44
[task 2019-01-12T15:46:23.522Z] 15:46:23 INFO - Finished waiting for state change: paused
[task 2019-01-12T15:46:23.524Z] 15:46:23 INFO - Finished waiting for state change: paused
[task 2019-01-12T15:46:23.525Z] 15:46:23 INFO - Waiting for state change: selected source
[task 2019-01-12T15:46:23.527Z] 15:46:23 INFO - Finished waiting for state change: selected source
[task 2019-01-12T15:46:23.528Z] 15:46:23 INFO - Resuming from 4
[task 2019-01-12T15:46:23.530Z] 15:46:23 INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
[task 2019-01-12T15:46:23.532Z] 15:46:23 INFO - Buffered messages logged at 15:45:45
[task 2019-01-12T15:46:23.534Z] 15:46:23 INFO - Console message: [JavaScript Error: "ReferenceError: foo is not defined" {file: "debugger eval code" line: 3}]
[task 2019-01-12T15:46:23.535Z] 15:46:23 INFO - @debugger eval code:3:34
[task 2019-01-12T15:46:23.538Z] 15:46:23 INFO - setTimeout handler*@debugger eval code:3:5
[task 2019-01-12T15:46:23.539Z] 15:46:23 INFO - @debugger eval code:2:16
[task 2019-01-12T15:46:23.539Z] 15:46:23 INFO - async*@debugger eval code:1:2
[task 2019-01-12T15:46:23.540Z] 15:46:23 INFO - getEvalResult@resource://devtools/server/actors/webconsole/eval-with-debugger.js:134:18
[task 2019-01-12T15:46:23.540Z] 15:46:23 INFO - exports.evalWithDebugger@resource://devtools/server/actors/webconsole/eval-with-debugger.js:105:18
[task 2019-01-12T15:46:23.540Z] 15:46:23 INFO - evaluateJS@resource://devtools/server/actors/webconsole.js:1037:22
[task 2019-01-12T15:46:23.541Z] 15:46:23 INFO - evaluateJSAsync@resource://devtools/server/actors/webconsole.js:942:22
[task 2019-01-12T15:46:23.541Z] 15:46:23 INFO - onPacket@resource://devtools/server/main.js:1275:15
[task 2019-01-12T15:46:23.541Z] 15:46:23 INFO - receiveMessage@resource://devtools/shared/transport/child-transport.js:66:5
[task 2019-01-12T15:46:23.541Z] 15:46:23 INFO - MessageListener.receiveMessage*_addListener@resource://devtools/shared/transport/child-transport.js:40:5
[task 2019-01-12T15:46:23.542Z] 15:46:23 INFO - ready@resource://devtools/shared/transport/child-transport.js:57:5
[task 2019-01-12T15:46:23.542Z] 15:46:23 INFO - _onConnection@resource://devtools/server/main.js:864:5
[task 2019-01-12T15:46:23.543Z] 15:46:23 INFO - connectToParent@resource://devtools/server/main.js:285:12
[task 2019-01-12T15:46:23.543Z] 15:46:23 INFO - onConnect</<@resource://devtools/server/startup/frame.js:50:22
[task 2019-01-12T15:46:23.543Z] 15:46:23 INFO - onConnect<@resource://devtools/server/startup/frame.js:49:7
[task 2019-01-12T15:46:23.543Z] 15:46:23 INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
[task 2019-01-12T15:46:23.544Z] 15:46:23 INFO - MessageListener.receiveMessage*@resource://devtools/server/startup/frame.js:72:5
[task 2019-01-12T15:46:23.544Z] 15:46:23 INFO - @resource://devtools/server/startup/frame.js:19:4
[task 2019-01-12T15:46:23.544Z] 15:46:23 INFO -
[task 2019-01-12T15:46:23.545Z] 15:46:23 INFO - Buffered messages finished
[task 2019-01-12T15:46:23.545Z] 15:46:23 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_jsterm_await_paused.js | Test timed out -
[task 2019-01-12T15:46:23.546Z] 15:46:23 INFO - Removing tab.
[task 2019-01-12T15:46:23.547Z] 15:46:23 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-01-12T15:46:23.548Z] 15:46:23 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-01-12T15:46:23.549Z] 15:46:23 INFO - Tab removed and finished closing
[task 2019-01-12T15:46:23.788Z] 15:46:23 INFO - Removing tab.
[task 2019-01-12T15:46:23.789Z] 15:46:23 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-01-12T15:46:23.808Z] 15:46:23 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-01-12T15:46:23.809Z] 15:46:23 INFO - Tab removed and finished closing

Nicolas, as you are the triage owner of this component, could you please take a look at this?
Thank you!

Flags: needinfo?(nchevobbe)
Whiteboard: [stockwell needswork]
Looking at the logs and the screenshots, it seems that the test fails
because the debugger is not paused anymore when evluating the await
expression, meaning that `foo` is undefined.
Here we try to wait for a small bit to give more time for the server
to evaluate before resuming.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0e161fee4d44
Fix intermittent on browser_jsterm_await_paused; r=Honza.
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Assignee: nobody → nchevobbe

clearing needinfo

Flags: needinfo?(nchevobbe)
You need to log in before you can comment on or make changes to this bug.