Closed Bug 1495728 Opened 2 years ago Closed 3 months ago

Remove ActorPool

Categories

(DevTools :: Framework, task, P3)

task

Tracking

(firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox79 --- fixed

People

(Reporter: ochameau, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

There is still a couple of usages of the old actors pools:
  https://searchfox.org/mozilla-central/source/devtools/server/actors/promises.js#102

Once this is done we should be able to easily remove old ActorPool specifics and close bug 881927, bug 1478973.
Severity: normal → enhancement
Priority: -- → P2
Attachment #9076399 - Attachment is obsolete: true

Switching to meta, filing bugs for individual files.

Type: enhancement → task
Keywords: meta
Priority: P2 → P3
Summary: Convert the usages of ActorPool to protocol.js Pool → [meta] Convert the usages of ActorPool to protocol.js Pool
Depends on: 1621707
Depends on: 1621710
Depends on: 1621712
Depends on: 1621713
Depends on: 1621715
Depends on: 1621716
Depends on: 1621717

Turning this into a regular bug where I'll remove ActorPool from the codebase, since we shouldn't have any usage of it anymore (after handling the blockers)

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Keywords: meta
Summary: [meta] Convert the usages of ActorPool to protocol.js Pool → Remove ActorPool

This class isn't used anymore, and it's safe to remove it.
Some comments are updated to not mention ActorPool.

Depends on D67510

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a49dd13ead35
Remove unused ActorPool class. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
Duplicate of this bug: 1600602
You need to log in before you can comment on or make changes to this bug.