Sommige tekens worden niet goed weergegeven in onderwerp van nieuwsbericht in berichtenlijst.

RESOLVED FIXED

Status

Mozilla Localizations
nl / Dutch
--
minor
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Tjibbe Steneker, Assigned: Taco Witte)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Bij berichten waar een ë (e-trema) voorkomt in de subject, en dit teken wordt
niet ge-escaped, wordt het hele onderwerp vanaf dit teken in de berichtenlijst
weergegeven als vraagtekens in ruitjes.

Dit probleem doet zich niet voor met het en-US langpack, maar wel met nl-NL (de
versie zoals die 6-6-2002 door Taco gepubliceerd is).

Dit probleem doet zich niet voor met berichten verstuurd met Mozilla, omdat met
dit programma vreemde tekens wel ge-escaped worden. Berichten waarbij ik dit
tegenkwam waren gepost met Forté Agent.

Workaround: kijk naar het onderwerp in het berichvenster eronder.
(Reporter)

Comment 1

16 years ago
Created attachment 86584 [details]
Screendump met het probleem duidelijk zichtbaar.
(Assignee)

Comment 2

16 years ago
Doet dit probleem zich ook voor als bij een en-US versie de UTF-8 tekenset wordt
geselecteerd? (Ik ben namelijk fan van Unicode, en heb dat dus ingesteld als
standaard.)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 3

16 years ago
Wat trouwens een hele makkelijke manier zou moeten zijn om de fout te vinden, is
om de Eigenschappen van de map op te vragen (bijvoorbeeld: rechtsklikken op
Postvak In en Eigenschappen kiezen; als het om Postvak In gaat), en vervolgens
de tekenset te veranderen.
(Assignee)

Comment 4

16 years ago
lijkt op http://bugzilla.mozilla.org/show_bug.cgi?id=9449
(misschien is er helemaal geen overeenkomst, maar het zou kunnen)
(Assignee)

Comment 5

16 years ago
Ik heb zelf eens geëxperimenteerd, en het blijkt volgens mij dat mijn vorige
suggestie inderdaad aangeeft dat daar het probleem zit: als bij een map wordt
ingesteld (via Eigenschappen van die map dus) dat een andere tekenset moet
worden gebruikt, werkt het wel (als het de goede tekenset is natuurlijk).
Dan is het dus niet mijn fout, maar een bug in Mozilla!

Omdat volgens mij het probleem hierin ligt, en dus niet door de vertaling komt,
markeer ik deze bug als FIXED. Als ik het mis heb, hoor ik het natuurlijk graag!

Bedankt voor het melden!
Met groet,
Taco
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

16 years ago
#4: Persoonlijk zie ik geen overeenkomsten, maar ik heb er dan ook niet zoveel
verstand van. Deze bug gaat niet over de titelbalk, maar over de berichtenlijst
in het 3-pane venster.

#5: Hoe verklaar je dan dat het probleem zich niet voordoet bij het en-US
langpack en wel bij nl-NL? Fixed is het in elk geval niet.
Summary: Sommige tekens worden niet goed weergegeven in onderwerp van nieuwsbericht in berichtenllijst. → Sommige tekens worden niet goed weergegeven in onderwerp van nieuwsbericht in berichtenlijst.
(Assignee)

Comment 7

16 years ago
>4: Persoonlijk zie ik geen overeenkomsten, maar ik heb er dan ook niet zoveel
>verstand van. Deze bug gaat niet over de titelbalk, maar over de berichtenlijst
>in het 3-pane venster.
Ik zeg niet dat er een overeenkomst _is_, maar ik verwacht wel dat intern in
Mozilla er een overeenkomst is (in de programmatuur). Of er een overeenkomst is
maakt op zich niet uit. (Anders zijn het twee losse bugs i.p.v. één bug die zich
op verschillende manieren laat zien.)
>
>#5: Hoe verklaar je dan dat het probleem zich niet voordoet bij het en-US
>langpack en wel bij nl-NL? Fixed is het in elk geval niet.
Probeer eens in een map waarin een bericht niet goed weergegeven om via
Eigenschappen (rechts klikken in die map) de tekenset (die nu op Unicode UTF-8
staat) te veranderen in ISO-8859-1. Dan zul je zien wat ik bedoel: in en-US
wordt Mozilla opgedragen om standaard ISO-8859-1 te gebruiken als tekenset,
terwijl ik in nl-NL Mozilla opdraag om Unicode altijd te gebruiken (dus ook in
dit geval). Dat is precies _het_ verschil. (In andere woorden: ik zeg dat
Mozilla Unicode moet gebruiken, maar er is een bug in Mozilla die er voor zorgt
dat Unicode niet altijd goed wordt weergegeven).

Ik hoop dat het nu wat duidelijker is.

Met groet,
Taco

ps: 'FIXED' is inderdaad niet helemaal van toepassing, maar de bug zit niet in
de vertaling, maar in een ander onderdeel van Mozilla (dat onderdeel dat voor de
weergave van berichten zorgt, en zoals ik verwacht, voor weergave van meer dan
alleen berichten).
You need to log in before you can comment on or make changes to this bug.