Closed Bug 1495822 Opened 3 years ago Closed 3 years ago

Google login autofill works in Focus+WebView, but not Focus+GV

Categories

(GeckoView :: General, defect, P2)

Unspecified
Android
defect

Tracking

(geckoview62 wontfix, firefox62 wontfix, firefox63 ?, firefox64 ?)

RESOLVED WORKSFORME
Tracking Status
geckoview62 --- wontfix
firefox62 --- wontfix
firefox63 --- ?
firefox64 --- ?

People

(Reporter: cpeterson, Assigned: m_kato)

References

Details

Oana reported a case where autofill works in Focus+WebView but not Focus+GV:

https://github.com/mozilla-mobile/focus-android/issues/3552

Steps to reproduce

1. Go to google.com and tap Sign in.
2. Long tap the email field.

Expected behavior

"Paste" and "Autofill" options are displayed.
Actual behavior

"Autofill" is not displayed using GeckoView, only on WebView.
Device information

* Android device: Samsung Galaxy Note 8 (Android 8.0), Huawei P9 Lite (Android 6.0)
* Focus version: 8.0, 7.0.10.
Oana says she used LastPass:

https://github.com/mozilla-mobile/focus-android/issues/3552#issuecomment-426532894

This bug might just be a dupe of LastPass bug 1330257 fixed in GV 63 (and WONTFIX'd for GV 62). Focus 7.0 (and 8.0 Nightly) still use GV 62. We will need to retest after Focus updates to GV 63.
Blocks: 1330257
Priority: -- → P2
62=wontfix because this is a known issue. We will need to retest after Focus Nightly updates to GV 63 (probably next week).
QA Contact: nchen
Assignee: nobody → m_kato
Product: Firefox for Android → GeckoView
Per https://github.com/mozilla-mobile/focus-android/issues/3552#issuecomment-447768771, this is WFM.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.