Closed Bug 14960 Opened 21 years ago Closed 20 years ago

[PP] page with fixed positioning causes crash

Categories

(Core Graveyard :: GFX, defect, P1, critical)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: dbaron, Assigned: waqar)

References

()

Details

(Keywords: crash, platform-parity)

Attachments

(1 file)

DESCRIPTION:  The above URL causes a crash.  It ends with the message:

Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 1647 error_code 11 request_code 53 minor_code 0

aborting...

I don't have a debug build, so I don't know what this is.  Marking compositor
and cc:ing troy, since he knows about fixed positioning.

This may be platform specific, but may not.

STEPS TO REPRODUCE:
Load http://www.fas.harvard.edu/~dbaron/css/test/sec1001e

ACTUAL RESULTS: Crash.

EXPECTED RESULTS: No crash.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-09-24-08-M11
 * Linux, viewer, 1999-09-26-09-M11

ADDITIONAL INFORMATION:

The display of the page for the short time it's visible doesn't look too great
either.
Status: NEW → ASSIGNED
Priority: P3 → P1
Could be linux GTK specific.
This is now only crashing some of the time.  (When I loaded the page after
starting viewer, and then scrolled, I crashed.  When I loaded the page on the
command line, I didn't crash.  I didn't try apprunner...)  The rest of the time
the display is completely mangled instead.

And actually, it's not truly a crash - the program just exits, so there's no
stack trace.
With the Dec 06 Linux build (1999120608), I can't get the application to crash or

exit on the sample url to get a stack trace.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Target Milestone: M13
Can we close this bug, then?
Status: RESOLVED → REOPENED
It just crashed for me (in a debug build from this morning's tree closure),
actually, when I went to see if I wanted to reopen changing the title from
"causes crash" to "is a mess".

It's erratic, but it still happens.  I'm reopening, for now...

Here's what I saw in the text window:

Document http://www.fas.harvard.edu/~dbaron/ loaded successfully
Document: Done (3.217 secs)
FindShortcut: in='http://www.fas.harvard.edu/~dbaron/css/test/sec1001e'
out='null'
failed to set the page title.
Document http://www.fas.harvard.edu/~dbaron/css/test/sec1001e loaded
successfully
Document: Done (1.393 secs)
Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 68047 error_code 11 request_code 53 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 68054 error_code 9 request_code 70 minor_code 0
david@dbaron ~/mozilla/src/mozilla/dist/bin >
Resolution: WORKSFORME → ---
sounds like your x server is running out of memory
Is it some special kind of memory?  I've got *lots* of memory free.
Target Milestone: M13 → M14
Assignee: beard → waqar
Status: REOPENED → NEW
Summary: page with fixed positioning causes crash → [PP] page with fixed positioning causes crash
Its not crashing on WINNT or WIN98. Marking as [PP] and reassigning to Waqar.
Status: NEW → ASSIGNED
It is not crashing on Linux as well. I am using 2000-01-14 build. I did see a
problem that http://www.fas.harvard.edu/~dbaron displays a gray screen. It
finishes rendering and then gray over the page and if you move mouse arround the
links show up with gray background.
That's a totally different bug:  bug 20185.  It has nothing to do with this.
This bug is hard to reproduce: it only crashes a small percentage of the time.
To reproduce this, it might help to open a bunch of windows.  That may have been
the case the last time I saw this.  I'm not really sure...
Well I opened 20 (twenty) different windows with this page, I also had couple of
other window with apprunner and I did not see the crash. I will keep trying
every once in a while and see if I can reporduce it.
Keywords: pp
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash
I am unable to crash with this test.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Keywords: verifyme
Bother, send too early. Sorry for the spam, ESC isn't bound yet =). Marking
verified.
Status: RESOLVED → VERIFIED
Sorry for the spam and confusion. I got confused between the processed bug and
bugzilla presenting the next bug.

Marking to VERIFIED still correct. The URL works for me on yesterdays tip built
locally (no valid build number).
Keywords: verifyme
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.