Closed Bug 1496025 Opened Last year Closed 3 days ago

Remove promises actor

Categories

(DevTools :: General, enhancement, P2)

enhancement

Tracking

(firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: ochameau, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Promises actor:
  https://searchfox.org/mozilla-central/source/devtools/server/actors/promises.js
has been landed as part of :gl's internship in an attempt to provide a panel displaying all page's promises with their status.
But so far, this actor has never been used in any production code.
This introduce some maintenance where we have to keep this code up to date regarding platform and devtools changes.

After rising this topic during last Devtools meeting, I got an overall approval to remove this code.
MozReview-Commit-ID: 55Y9FrpXCL1
MozReview-Commit-ID: BPsMPaLz8AM

Depends on D7689
I ended up also removing tests from the debugger, which were testing both PromisesFront and a couple of API on WebConsoleActor specific to promises:
  devtools/client/debugger/test/mochitest/browser_dbg_promises-*.js

But same as PromisesActor, these methods weren't used in the product:
  https://searchfox.org/mozilla-central/source/devtools/server/actors/object.js#727-860
Nicolas is away this week and the following, so asking for feedback about these APIs to Honza.
Severity: normal → enhancement
Priority: -- → P2
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9a6fdac66bb
Remove Promises actor r=gl
https://hg.mozilla.org/integration/autoland/rev/1292fd4850a7
Remove unused methods on ObjectClient related to promises r=Honza,gl
Arf... Promises actor is being used by android test framework introduced in bug 1461746.
Flags: needinfo?(poirot.alex)
No longer blocks: 1492265
The Promises actor is being used from here:
  https://searchfox.org/mozilla-central/source/mobile/android/geckoview/src/androidTest/java/org/mozilla/geckoview/test/rule/GeckoSessionTestRule.java#2059-2071

We might be able to refactor this by using Reps or the API removed in the second changeset:
  https://bugzilla.mozilla.org/attachment.cgi?id=9014284
As tagging objects like that are pure hack and sounds like something that should be done via ObjectClient.

But I don't have enough cycles to look into this.
Assignee: poirot.alex → nobody
Duplicate of this bug: 1438190

Looks like all the dependencies on DevTools promises actor was removed with https://hg.mozilla.org/integration/autoland/rev/fa0cb607fe0d in Bug 1553515.

We should be able to retry this. I will rebase the patches.

Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Attachment #9101937 - Attachment description: Bug 1496025 - Remove Promises actor r=gl → Bug 1496025 - Remove Promises actor
Attachment #9101940 - Attachment description: Bug 1496025 - Remove unused methods on ObjectClient related to promises r=Honza,gl → Bug 1496025 - Remove unused methods on ObjectClient related to promises
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b838594432f8
Remove Promises actor r=ochameau
https://hg.mozilla.org/integration/autoland/rev/6acfae11770c
Remove unused methods on ObjectClient related to promises r=ochameau
Status: ASSIGNED → RESOLVED
Closed: 3 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.