Various crashes in file selector

VERIFIED WORKSFORME

Status

Core Graveyard
File Handling
VERIFIED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Sam Rowe, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If I click on 'mp3' in the "Media" section (in red) I'm presented with the
standard "what do you want to open this with?" dialog. It defaults to mpg123 and
I wanted to select XMMS. The first time I tried it, I clicked Choose and used
the menu-drop-down to go from /home/sam to /  Then I used the mousewheel to
scroll down to /usr. Crash.

I downloaded the latest build
http://komodo.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu.tar.gz

I tried again. This time the crash didn't occur when mousewheeling, but
immediately after when I double-clicked on /usr.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020606

I wasn't sure what product or component to use, sorry.
Any chance of a talkback ID?
(Reporter)

Comment 2

16 years ago
I'm not using a talkback build, sorry.
What I meant was, "Could you please reproduce this in a talkback build?"  Sorry 
I was not clear.  ;)
(Reporter)

Comment 4

16 years ago
Is there a way to use talkbalk w/o having to go through the installer process...
ie a tarball that I can just dump out?

Comment 6

16 years ago
what filesystem are you using?

Does it always crash in /usr ? (also in a 'normal' open-file dialog? CTRL+o)

..maybe you have a very unusual named file/folder in /usr...

btw: broken filesystems are able to crash any app :) .. what does fsck say?
(Reporter)

Comment 7

16 years ago
I'm using ReiserFS. I don't think it's a filesystem problem, as I just tried it
again to see if it was a problem with /usr and it crashed immediately when I
clicked "Choose."

I'm also able to browse the filesystem using File | Open File.
This will be very difficult to confirm or fix unless we can get a stack trace,
either from a talkback build or from running in the debugger.
reporter (Sam Rowe): can you reproduce this bug with a recent build of mozilla
(for example, 1.1beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 10

16 years ago
I don't have the perms to change Status, but it is worksforme.

Comment 11

16 years ago
-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.