Closed Bug 1496079 Opened 2 years ago Closed 2 years ago

cannot view files due to missing READ_STORAGE_PERMISSION

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox62 --- wontfix
firefox63 --- verified
firefox64 --- verified

People

(Reporter: andrei.a.lazar, Assigned: andrei.a.lazar)

References

Details

(Keywords: regression)

Attachments

(1 file)

This is a regression from bug 1451061.

Steps to reproduce:
1) Find an .html file using any file manager
2) Open using Fennec

Expected behavior:
Fennec opens the .html file in a new tab and shows its content

Actual behavior:
Fennec opens the .html file in a new tab and shows an "access file denied" message.
Depends on: 1406903
Fixed the issue where the read storage permission was not requested due to a typo.
Keywords: checkin-needed
(In reply to Andrei Lazar from comment #0)
> This is a regression from bug 1451061.

Really? As far as I can tell, this was already introduced in the original implementation in bug 1271570 (https://hg.mozilla.org/mozilla-central/rev/e6109363cd6e). Still, good find, thanks for spotting this.
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b019dd902c4
cannot view files due to missing READ_STORAGE_PERMISSION r=JanH
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9b019dd902c4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Please request Beta approval on this when you get a chance.
Blocks: 1271570
Flags: qe-verify+
Flags: needinfo?(andrei.a.lazar)
Comment on attachment 9014030 [details]
Bug 1496079 cannot view files due to missing READ_STORAGE_PERMISSION r=JanH

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1271570

User impact if declined: cannot view files due to missing READ_STORAGE_PERMISSION

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Small change, already tested by QA in Nightly.

String changes made/needed:
Flags: needinfo?(andrei.a.lazar)
Attachment #9014030 - Flags: approval-mozilla-beta?
Comment on attachment 9014030 [details]
Bug 1496079 cannot view files due to missing READ_STORAGE_PERMISSION r=JanH

Fix for a 62 regression caused by a typo in a function call, on nightly for a week, approved for our last 63 beta for Android, thanks.
Attachment #9014030 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(ioana.chiorean)
Verified in the latest Nightly (2018-10-16) and Beta (63.0b15) builds, I was able to access the HTML file without any kind of issues.

Methods used:
 - steps from Comment 0 using a file manager
 - directly by accessing the file from FF by navigating through storage
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(ioana.chiorean)
Hardware: Unspecified → ARM
You need to log in before you can comment on or make changes to this bug.