Closed Bug 149627 Opened 20 years ago Closed 20 years ago

mailto: (external reader) clicking on link crashes moz

Categories

(MailNews Core :: Simple MAPI, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mrroach, Assigned: dveditz)

Details

(Keywords: crash, helpwanted, testcase)

Attachments

(1 file, 1 obsolete file)

If I install mozilla 1.0 without mail/news or I put 
user_pref("network.protocol-handler.external.mailto", true);
in user.js, clicking on a mailto link crashes mozilla. 

The default mail handler is outlook 2000. 

I am using a talkback enabled build and entered my email address in crash dialog
but I don't know how to reference it here.
It looks like this only happens on mailto links of a certain size. The link my
user is clicking on is 3901 characters. This should still not cause a crash. Am
attaching a mailto that causes this crash.

Being able to click long mailto links was part of what convinced my users to
switch over in the first place so this is important to me. Thanks for all your
help, folks!
Attached file mailto link that crashes mozilla (obsolete) —
To display talkback IDs, run "talkback.exe":
C:\Program Files\mozilla.org\Mozilla\components\talkback.exe
I put the suggested mailto into this testcase.	I don't crash clicking it in
built 2002071608 PC/Win98, but I don't get a mail window either.  Nothing
happens.

When you view source in Mozilla, the A tag has a big blotch of whitespace at
the end of the mailto content.	I assume because of the length, Moz is just
dropping some of the code.

Reporter, if you are still having crashes in a current build, we still need the
Talkback IDs.  See previous comment for how to retrieve them.
Attachment #86616 - Attachment is obsolete: true
Added kw testcase.
Keywords: testcase
OK, just updated to latest nightly and got a crash again
talkback id TB8555156H

Thanks.
This particular stack trace is not extremely helpful.

Product ID MozillaTrunk
Build ID 2002072204
Operating System Windows NT 5.0 build 2195
URL visited test case
Trigger Reason Access violation

Stack Trace
0x00610061
0x00610061 
After uninstalling my previous build and installing the 1.1 beta milestone
(build 2002072204), I am now crashing when I click the link in the testcase.

Talkback IDs: TB8582744H and TB8582754G

Marking as NEW on that basis, adding kw crash and severity->critical.

As suggested in the bug description, my installation of Mozilla (both previously
and currently) is without the mail/news component.  Eudora 5 is my mail handler.

I also tried created a new profile and got another crash, Talkback ID TB8582919E
Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
-> Networking
Assignee: Matti → new-network-bugs
Component: Browser-General → Networking
QA Contact: imajes-qa → benc
+escalation to engineering.
Keywords: helpwanted
nominated for next release.

Does this happen if mailnews is on? Tha would help isolate the problem.
Keywords: nsbeta1
Summary: clicking on mailto link crashes moz → mailto: (external reader) clicking on link crashes moz
to mailnews for triage.
Component: Networking → Simple MAPI
Product: Browser → MailNews
to default.
Assignee: new-network-bugs → rdayal
QA Contact: benc → trix
This is a duplicate of bug 161357 (a particular instance of the general case).

External handlers go through the windows API ShellExecute() which imposes length
limits. On Win9x they're pretty short, about 460 or so characters, while on
WinNT-based os's it appears to accept URLs up to around 2K in length. We're
fixing the crash, but you're not ever going to get your 3900 char mailto: url to
work with an external mail program (not with IE either). Internal to Mozilla we
handle extremely long URLs, but unless you know that only Mozilla browsers with
Mozilla mail are visiting your pages you shouldn't count on that.

Taking.
Assignee: rdayal → dveditz
fix will be in 1.2 and 1.0.2
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
changing qa contact to yulian
QA Contact: trix → yulian
QA Contact: yulian → stephend
verified per verification of test case in duplicate 161357. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.