Closed Bug 1496523 Opened Last year Closed 11 months ago

build bustage: comm-beta 63 tasks failing

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 63.0

People

(Reporter: rjl, Assigned: rjl)

Details

Attachments

(2 files)

The generated .mozconfig ends up trying to use nodejs and fails. Need to compare to other branches and see what's different in comm-beta. Nodejs isn't really necessary for this.

https://treeherder.mozilla.org/logviewer.html#?job_id=203197408&repo=comm-beta&lineNumber=712
release-balrog-submit-toplevel-thunderbird-bz2 rel(bptb-bz2) fails due to misconfigured task.
However, we don't need the bz2 MAR files on beta, so this task needs to be disabled.
Summary: build bustage: release-source-thunderbird-source fails on comm-beta 63 → build bustage: comm-beta 63 tasks failing
The generated .mozconfig file for building the source tarball will require
nodejs to be present. Firefox has included in their mozconfig for source
builds:
ac_add_options --disable-nodejs
Comment on attachment 9014585 [details]
Bug 1496523 - Remove nodejs requirement for building source package

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
The source tarballs for beta are not produced and therefore will be unavailable for users to download.
Testing completed (on c-c, etc.):
"mach configure" followed by "make source-package" in the object dir. Observed that source tarball was built as expected.
Risk to taking this patch (and alternatives if risky):
Attachment #9014585 - Flags: approval-comm-beta?
This just removes the two bz2 mar balrog jobs from comm-beta as there is not a better way to disable them without bringing in bug 1490094 to both mozilla-beta and comm-beta.

This patch should only be applied to comm-beta.

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Tested locally with mach taskgraph. Verified that release-balrog-submit-toplevel-thunderbird-bz2 rel(bptb-bz2) is not in the list of tasks to run.
Risk to taking this patch (and alternatives if risky):
Attachment #9014619 - Flags: review?(mozilla)
Attachment #9014619 - Flags: approval-comm-beta?
Comment on attachment 9014619 [details] [diff] [review]
Remove bz2 mar jobs in comm-beta

Review of attachment 9014619 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine for beta. A different patch should probably be landed for c-c.
Attachment #9014619 - Flags: review?(mozilla) → review+
Since we have "run-on-releases: [esr60]" on c-c, the bz2 task won't run, right?

https://hg.mozilla.org/comm-central/file/tip/taskcluster/ci/release-balrog-submit-toplevel/kind.yml#l69
Attachment #9014585 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #9014619 - Flags: approval-comm-beta? → approval-comm-beta+
https://hg.mozilla.org/releases/comm-beta/rev/12d438eb06957eeec680dfcf3fb0e98058c679cc
https://hg.mozilla.org/releases/comm-beta/rev/211689650f6b70e992de3c14666670cc63338c1b

The friendly sheriff sprinkled in a bit of punctuation, capitalisation and removed trailing spaces.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
Comment on attachment 9014585 [details]
Bug 1496523 - Remove nodejs requirement for building source package

Jörg, please apply this patch to comm-beta (tb 64) and c-c (tb 65)
Flags: needinfo?(jorgk)
Re-opening so attachment 9014585 [details] can be applied to C-C and beta-64. I've reopened the patch in Phabricator so it can be landed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I don't need reopened bugs or changes to Phabricator, I will just land the patch.
Flags: needinfo?(jorgk)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0399d51b31fe
Remove nodejs requirement for building source package. r=tomprince DONTBUILD
Status: REOPENED → RESOLVED
Closed: Last year11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.