Download Manager doesn't show up when a clicked linked is a file which can be opened or saved to disk.

VERIFIED DUPLICATE of bug 149261

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 149261
16 years ago
13 years ago

People

(Reporter: Sachin Arora, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Platform: PC
OS: Windows 2000 Professional SP2
Mozilla Build ID: 2002060508
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+) Gecko/20020605

When I click on a link and a dialog box appears asking me if I want to open the
file or save it to the disk, anything I choose (open/save) the download manager
doesn't show up.  Even though I can see from my network activity that file is
being downloaded and on case of saving the file, the file is actually saved to
disk but no dialog box, no download manager appears.

So, if this is a big file and I want to cancel opening/downloading such a file,
the only method is to quit mozilla. :-(

Though if I right click on such files and say "Save Link As" then the Download
Manager shows up alright.

Reproducibility: Always

Steps to reproduce:
1. Go to
http://www.rpmfind.net//linux/RPM/rawhide/1.0/i386/RedHat/RPMS/mutt-1.4-2.i386.html
2. Click on 'mutt-1.4-2 RPM for i386'
3. Choose 'Save file to disk'

OR

1. Go to http://www.dgp.toronto.edu/~schubert/
2. Click on 'thesis.ps'  (33.6 MB file)
3. Choose open and click OK.

OR 

1. Go to http://www.dgp.toronto.edu/~schubert/
2. Click on 'drawtex1.exe' or 'drawtex2.exe' or 'drawtex3.exe'
3. Choose save file to dik and click OK.


Actual Results:
The files are saved/opened alright but download manager or any download progress
window doesn't appear.  And there is no way to cancel the downloads if I decide
to cancel downloading some big file like 'thesis.ps' as mention above.

Expected Results:
Download manager should appear showing the progress of downloads.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 149261 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.