Closed Bug 1496724 Opened 3 years ago Closed 3 years ago

Master password not requested in about:preferences immediately after being set

Categories

(Toolkit :: Password Manager, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix

People

(Reporter: cfogel, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:
- 63.0b12

[Affected platforms]:
- win 10x64, macOS 10.11, Ubuntu 16.04

[Steps to reproduce]:
1. launch Firefox with a fresh profile;
2. Set and save any account+password for any website;
3. Restart the browser;
4. Access: about:preferences#privacy 
5. Check the Use a master password box;
6. Click on the Change master password button;
7. Enter a valid password and save to close the menu;
8. Click on the Saved Logins button.

[Expected result]:
- master password input field is displayed

[Actual result]:
- saved logins section is opened

[Regression range]:
- will check for the regression range asap

[Additional notes]:
- 62.0.3, 64.0a1 (2018-10-05) was not affected by this issue;
Hmm… I triaged a bug similar to this a few months ago I think… If you restart between step 7 and 8 then everything is fine I believe, right? It's not a huge deal if the MP takes effect on the next restart but I'm surprised this is a regression.
Flags: needinfo?(cristian.fogel)
Component: Form Autofill → Password Manager
Yes, after a restart it it ok.
bug 1481483 - probably since it was somewhat similar.
Flags: needinfo?(cristian.fogel)
Right, that was it. How come that bug affects 61 but you're saying it only affects 63 but not 64. Something weird must be going on. Can we dupe to bug 1481483 or is it different?
Flags: needinfo?(cristian.fogel)
*Re-tested with 61.0a1 (2018-04-01), 62.0b16, 64.0a1 (2018-10-04), 62.0.3.
Since I managed to reproduce on the above mentioned versions, updating the flag as well.

*Step 3 is not needed to reproduce this issue;

*As far as marking it as a dupe, the steps needed to reproduce are a bit different since here the restart would no longer cause the issue
If the fix would be around checking the state of the master password before opening the "Show Passwords" section then probably both can be fixed at once.

*Found the regression range as well:
- pushlog url:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a6a1f5c1d971dbee67ba6eec7ead7902351ddca2&tochange=4f4487cc2d30d988742109868dcf21c4113f12f5
Flags: needinfo?(cristian.fogel)
See Also: → 1481483
Summary: [63-beta] Master password not requested in about:preferences areas → Master password not requested in about:preferences areas
Matt, does anything from that push range look related?

How serious is this?
Flags: needinfo?(MattN+bmo)
(In reply to Mike Taylor [:miketaylr] (62 Regression Engineering Owner) from comment #5)
> Matt, does anything from that push range look related?

Yes, that helps a lot. Looks like this was an intentional change from bug 1386955. See https://hg.mozilla.org/mozilla-central/rev/403576c827b7#l1.12 for test changes confirming this.

I think the actual result is fine, the important thing is for the MP prompt to appear when the "Show Passwords" button is clicked. Cristi, can you confirm that the MP dialog always appears in the dialog when "Show Passwords" is clicked, including as a step 9 in your original STR.
Blocks: 1386955
Flags: needinfo?(MattN+bmo) → needinfo?(cristian.fogel)
Summary: Master password not requested in about:preferences areas → Master password not requested in about:preferences immediately after being set
Yes, the MP dialog appears on Show passwords.

However it does not appear when Clicking the Remove/Remove all buttons. 
Is that intended?
Flags: needinfo?(cristian.fogel)
(In reply to Cristi Fogel [:cfogel] from comment #7)
> Yes, the MP dialog appears on Show passwords.
> 
> However it does not appear when Clicking the Remove/Remove all buttons. 
> Is that intended?

Yes, there is another bug about that but we think that's fine. The purpose of the MP prompt there is only to prevent showing the plaintext passwords, not to prevent changes (you can also edit the username without entering the MP).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.