onfocus event for input type="file"

VERIFIED DUPLICATE of bug 4033

Status

()

defect
VERIFIED DUPLICATE of bug 4033
17 years ago
a month ago

People

(Reporter: ben, Assigned: joki)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The onfocus event for a form input field where type is set to "file" does not
appear to work.  The URL above has an example with two identical forms.  In the
first example the input fields are both type "text" and the onfocus event works
as expected.  In the second example one of the input fields is type "file" and
the onfocus event does not appear to work.

Have tested on RC3 and 1.0 on Win2K with the same results under each version.  I
have not tested on other platforms.  No errors appear in the JS Console.  I was
unable to find other bug submissions that relate to this.

Comment 1

17 years ago
Browser, not engine ---> Event Handling 
Assignee: rogerl → joki
Component: JavaScript Engine → Event Handling
QA Contact: pschwartau → rakeshmishra

Comment 2

17 years ago
I see the same thing with Mozilla 2002060408/WinNT.  When the "Browse..." button
from the <input type="file"> gets focus, the onfocus event is fired, but not
when the textbox part of the <input type="file"> gets focus.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 4033 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: rakeshmishra → trix

Comment 4

17 years ago
verifying dupe
Status: RESOLVED → VERIFIED
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.