Perma mch (tier2) testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set TEST-UNEXPECTED-FAIL

RESOLVED FIXED in Firefox 64

Status

defect
P1
normal
RESOLVED FIXED
10 months ago
8 months ago

People

(Reporter: intermittent-bug-filer, Assigned: ahal)

Tracking

({intermittent-failure})

Version 3
mozilla64
Points:
---

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=203725538&repo=autoland

https://queue.taskcluster.net/v1/task/Tbax7K2vS4KsttezjTEVGw/runs/0/artifacts/public/logs/live_backing.log

[task 2018-10-05T19:48:29.182Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2018-10-05T19:48:29.199Z] cat: backend.TestManifestBackend.in: No such file or directory
[task 2018-10-05T19:48:29.201Z] Build configuration changed. Regenerating backend.
[task 2018-10-05T19:48:29.679Z] No handlers could be found for logger "mozbuild.frontend.reader"
[task 2018-10-05T19:48:34.022Z] No build detected, test metadata may be incomplete.
[task 2018-10-05T19:48:34.883Z]  0:00.12 INFO Creating config file /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/wptrunner.local.ini
[task 2018-10-05T19:48:34.884Z]  0:00.12 INFO Creating directory /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/meta
[task 2018-10-05T19:48:34.885Z]  0:00.12 INFO Creating directory /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/mozilla/meta
[task 2018-10-05T19:48:36.237Z]  0:01.47 WARNING No generated manifest found
[task 2018-10-05T19:48:36.237Z]  0:01.47 INFO Recreating manifest /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/meta/MANIFEST.json
[task 2018-10-05T19:51:44.135Z]  3:09.37 INFO Recreating manifest /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_tests/web-platform/mozilla/meta/MANIFEST.json
[task 2018-10-05T19:51:48.158Z]  3:36.38 /builds/worker/checkouts/gecko/testing/mochitest/tests/python/test_get_active_tests.py
[task 2018-10-05T19:51:48.159Z]  3:36.38 ============================= test session starts ==============================
[task 2018-10-05T19:51:48.160Z]  3:36.38 platform linux2 -- Python 2.7.12, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-2/bin/python
[task 2018-10-05T19:51:48.160Z]  3:36.38 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2018-10-05T19:51:48.160Z]  3:36.38 collecting ... collected 1 item
[task 2018-10-05T19:51:48.160Z]  3:36.38 
[task 2018-10-05T19:51:48.160Z]  3:36.38 testing/mochitest/tests/python/test_get_active_tests.py::test_prefs_validation PASSED
[task 2018-10-05T19:51:48.160Z]  3:36.38 
[task 2018-10-05T19:51:48.160Z]  3:36.38 =========================== 1 passed in 0.35 seconds ===========================
[task 2018-10-05T19:51:48.191Z]  3:36.41 /builds/worker/checkouts/gecko/testing/mochitest/tests/python/test_build_profile.py
[task 2018-10-05T19:51:48.191Z]  3:36.41 ============================= test session starts ==============================
[task 2018-10-05T19:51:48.191Z]  3:36.41 platform linux2 -- Python 2.7.12, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-2/bin/python
[task 2018-10-05T19:51:48.191Z]  3:36.41 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2018-10-05T19:51:48.191Z]  3:36.41 collecting ... collected 1 item
[task 2018-10-05T19:51:48.192Z]  3:36.41 
[task 2018-10-05T19:51:48.192Z]  3:36.41 testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set TEST-UNEXPECTED-FAIL
[task 2018-10-05T19:51:48.192Z]  3:36.41 
[task 2018-10-05T19:51:48.192Z]  3:36.41 =================================== FAILURES ===================================
[task 2018-10-05T19:51:48.192Z]  3:36.41 ________________________ test_common_prefs_are_all_set _________________________
[task 2018-10-05T19:51:48.192Z]  3:36.41 
[task 2018-10-05T19:51:48.192Z]  3:36.41 build_profile = <function inner at 0x7f87fa2ca5f0>
[task 2018-10-05T19:51:48.193Z]  3:36.41 profile_data_dir = '/builds/worker/checkouts/gecko/testing/profiles'
[task 2018-10-05T19:51:48.193Z]  3:36.41 
[task 2018-10-05T19:51:48.193Z]  3:36.41     def test_common_prefs_are_all_set(build_profile, profile_data_dir):
[task 2018-10-05T19:51:48.193Z]  3:36.41         # We set e10s=False here because MochitestDesktop.buildProfile overwrites
[task 2018-10-05T19:51:48.193Z]  3:36.41         # the value defined in the base profile.
[task 2018-10-05T19:51:48.193Z]  3:36.41         # TODO stop setting browser.tabs.remote.autostart in the base profile
[task 2018-10-05T19:51:48.194Z]  3:36.41 >       md, result = build_profile(e10s=False)
This is a regression from bug 1470266. From the log:

[task 2018-10-05T19:54:09.234Z]  3:36.02 >       self.profile.set_preferences(self.extraPrefs)
[task 2018-10-05T19:54:09.234Z]  3:36.02 E       AttributeError: 'MochitestDesktop' object has no attribute 'extraPrefs'
Flags: needinfo?(ahal)
Summary: Intermittent 3:36.01 testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set TEST-UNEXPECTED-FAIL → Perma mch (tier2) testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set TEST-UNEXPECTED-FAIL
Should be a simple fix, I'll get it landed soon.
Flags: needinfo?(ahal)
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f81c0fafcb2f
[mochitest] Fix mochitest selftest regression by always instantiating self.extraPrefs, r=jmaher
Assignee: nobody → ahal
Status: NEW → ASSIGNED
Priority: P5 → P1
https://hg.mozilla.org/mozilla-central/rev/f81c0fafcb2f
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.