Closed Bug 1496855 Opened Last year Closed Last year

Built-in PDF viewer is not disabled by a policy

Categories

(Firefox :: Enterprise Policies, defect)

64 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- verified
firefox64 --- verified

People

(Reporter: StefanG_QA, Assigned: mkaply)

References

Details

(Keywords: regression)

Attachments

(2 files)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:64.0) Gecko/20100101 Firefox/64.0 (20181005102516)

STR:

1.Open Terminal and type:
`defaults write org.mozilla.nightly EnterprisePoliciesEnabled -bool YES`
`defaults write org.mozilla.nightly DisableBuiltinPDFViewer -bool YES`
2. Open Firefox
3. navigate to about:policies and verify the activated policy is displayed (true)
4. Go to https://www.irs.gov/pub/irs-pdf/p1.pdf and verify the browser does not open the pdf file, instead, the file is downloaded.


AR: Browser is using the built-in PDF viewer to display the file
ER: Browser should download the file instead
5. Go to about:preferences ->Applications and verify:
    5.1- the content type 'PDF file' does not have value in "Action" column
    5.2 Click the downward arrow and verify 'preview in Nightly' is not listed

ER: The content type 'PDF file' does not have value in "Action" column and 'preview in Nightly' is not listed
Weird. This isn't setting the preference properly. I know it worked in our past testing.
OS: Mac OS X → All
Hardware: Unspecified → All
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Blocks: 1479245
Keywords: regression
pdfjs.disabled now works from policy, so use it
I've tested this using json file and the result is the same. Upon loading the file is displayed in PDFviewer instead of downloaded.
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/461d609b9d2d
Switch PDF policy to use pdfjs.disabled. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/461d609b9d2d
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Is this something we should consider backporting to 63 with the RC being next week, or can it ride the trains?
Flags: needinfo?(mozilla)
Comment on attachment 9015933 [details]
Bug 1496855 - Switch PDF policy to use pdfjs.disabled.

We should backport. This should be very clean.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1479245

User impact if declined: Policy to disable built in PDF no longer works.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Documented in bug.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Very isolated. Switched to using pref that already existed.

String changes made/needed:
Flags: needinfo?(mozilla)
Attachment #9015933 - Flags: approval-mozilla-beta?
Comment on attachment 9015933 [details]
Bug 1496855 - Switch PDF policy to use pdfjs.disabled.

Looks safe and contained and landed on nightly, uplift approved for 63 beta 14.
Attachment #9015933 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I've verified this issue as fixed on the latest Nightly build (2018101100123). When the policy is activated the browser is not using the built-in PDF viewer to display the file, instead, the file is downloaded.
Status: RESOLVED → VERIFIED
No longer depends on: 1445943
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13.6; rv:63.0) Gecko/20100101 Firefox/63.0

I was able to reproduce the mentioned behavior on macOS using Beta 63.0b13. 

The issue is verified as fixed on the latest Beta 63.0b14. When the policy is activated the browser is not using the built-in PDF viewer to display the file, instead, the file is downloaded.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.