Mail context menu starts with separator in "normal" folders, not Drafts and Templates

VERIFIED FIXED in Thunderbird 64.0

Status

enhancement
VERIFIED FIXED
10 months ago
9 months ago

People

(Reporter: jorgk, Assigned: Paenglab)

Tracking

Thunderbird 64.0

Thunderbird Tracking Flags

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

Details

Attachments

(1 attachment)

Looks like there is a mechanism to hide "Edit Draft Message" and "New Message from Template" / "Edit Template", but it forgot to hide the following separator.

Looks slightly odd in TB 60 and I'm surprised no one has complained yet.

Richard, could you please take a look.
Flags: needinfo?(richard.marti)
No, your separator is in the Go menu. It's more this one.
https://searchfox.org/comm-central/rev/42bb5729167259ec2cdcabdb4bb816ae91b4156f/mail/base/content/mainPopupSet.inc#1300
Flags: needinfo?(richard.marti)
Right, and the context menu seems to be done in code:
https://searchfox.org/comm-central/source/mail/base/content/mailContextMenus.js

And there they are busily hiding the draft and edit commands but not the separator :-(
This should do it.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9015084 - Flags: review?(jorgk)
Comment on attachment 9015084 [details] [diff] [review]
1497009-hideSeparator.patch

Works great. Thanks. Finally I'll get rid of the ugly separator. Obviously not many people know this trick.
Attachment #9015084 - Flags: review?(jorgk)
Attachment #9015084 - Flags: review+
Attachment #9015084 - Flags: approval-comm-esr60+
Attachment #9015084 - Flags: approval-comm-beta+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/bf1c31c2f2b2
Add the mailContext-sep-editTemplate separator to the hideIfAppropriate group. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Confirmed working in ESR build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.