Closed Bug 1497053 Opened Last year Closed Last year

Importing Saved Password Causes Freeze and Script error on Firefox Nightly

Categories

(Toolkit :: Password Manager, defect)

64 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1429560
Tracking Status
firefox64 --- affected

People

(Reporter: amantu.khan2013, Unassigned, NeedInfo)

Details

Attachments

(1 file)

Attached image 2018-10-07.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Steps to reproduce:

1. Go to about:preferences#general and Search for saved logins.
2. Click Import.
3. It'll pop up a window which will ask for a browser to export.
3. Only Check Saved Passwords
4. Click Next, and it'll cause Firefox to freeze and eventually crash.

Eventually, after relaunching the browser I can find passwords has been imported. But when I tried to delete all saved password Firefox crashed again.


Actual results:

It Freezes and shows this message: 
"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://passwordmgr/content/passwordManager.js:246"


Expected results:

It should import saved password easily.
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0 (20181010100123)

I 've tested this report on Windows 10 x64 using the latest Nightly and Fx release builds. I did not manage to reproduce the issue. When importing passwords I did not experience crash or freeze. However, when I tried to delete all passwords I noticed a short freeze for a ~3-5 seconds. 

Could you provide the crash reports for the mentioned crashes from about:crashes?
Component: Untriaged → Password Manager
Flags: needinfo?(amantu.khan2013)
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1429560
You need to log in before you can comment on or make changes to this bug.