Closed Bug 1497152 Opened 2 years ago Closed 2 years ago

Take the various box-model regions into account when displaying flex item sizing information

Categories

(DevTools :: Inspector, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1496463

People

(Reporter: pbro, Unassigned)

References

Details

In the flex sizing information section, we display values such as the base size, the growth, the min/max sizes, and final size.
Alongside with them, we also display (when found) the authored CSS properties that caused these values.
However, depending the current box-sizing property and depending on padding or border, these may differ.
You may have a flex-basis:100px with a base size being 80px.

This will confuse users and we should make changes to the UI so that it's straightforward to understand that the delta may come from padding or border.
I think this bug and bug 1496463 might roughly be duplicates -- feel free to dupe in either direction.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1496463
You need to log in before you can comment on or make changes to this bug.