Closed Bug 1497226 Opened 3 years ago Closed 3 years ago
Extension Target Actor .id and Addon Target Actor .id to addon Id
46 bytes, text/x-phabricator-request
|Details | Review|
Followup to bug 1492265. Using "id" looks very generic and might easily collide with similar field defined in the parent class (BrowsingContextTargetActor). So it would be better to renamed this attribute to "addonId".
Summary: Rename WebExtensionTargetActor.id to addonId → Rename WebExtensionTargetActor.id and AddonTargetActor.id to addonId
Pushed by firstname.lastname@example.org: https://hg.mozilla.org/integration/autoland/rev/80a1352b7cd9 Rename WebExtensionActor/WebExtensionTargetActor/AddonTargetActor.id to addonId. r=jdescottes
You need to log in before you can comment on or make changes to this bug.