Closed Bug 1497457 Opened 11 months ago Closed 9 months ago

[remote-dbg-next] Share a single client between about:debugging and about:devtools-toolbox

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox65 fixed)

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

Attachments

(7 files)

We should be able to reuse clients created when we initially connected to a device whenever we:
- reload about:debugging
- debug a new target

This will reduce the number of connection prompts that might appear on the Device and will allow make features such as Bug 1497454 easier to implement.
Priority: P3 → P2
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
Depends on: 1506056
Attachment #9025279 - Attachment description: Bug 1497457 - Allow to remove one time listeners on event-source;r=daisuke,ochameau → Bug 1497457 - Allow to remove one time listeners on event-source;r=ochameau
Depends on D12040. If we don't cleanup the clients after the test, some tests may leak.
Depends on D12095. Now that we pass a remoteId to open about:devtools-toolbox, we actually don't need transportDetails
Blocks: 1509125
I have tested bug 1501164 while applying above patches, it seems this fix the bug 1501164 as well.
Thanks! After closing this bug, I'll check again.
See Also: → 1501164
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0e93acc09952
Allow to remove one time listeners on event-source;r=ochameau
https://hg.mozilla.org/integration/autoland/rev/95365a2d7470
Introduce remote client manager to persist connected remote clients;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/f2a39a18f2f6
Test runtime is still connected after about:debugging reload;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/9923755ee205
Reuse clients from remote client manager in about:devtools-toolbox;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/b2830500918c
Clear clients stored in remote client manager after tests;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/bd490139b395
Remove transportDetails from runtimeDetails;r=daisuke,ladybenko
r+ test-only for a patch than landed in between
Attachment #9027698 - Flags: review+
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d3b46f3a0306
Fix aboutdebugging systemaddons test after signature change; r=fix
Sorry about that, there was an undetected debug failure after one of the last rebases. Reopened, pushed to try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4d565254eb806358c49c565ac1dd1b6405019e6b

I will wait until the next merge from autoland to central to land again.
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b078b2df55db
Allow to remove one time listeners on event-source;r=ochameau
https://hg.mozilla.org/integration/autoland/rev/fe4c1c6d7ebf
Introduce remote client manager to persist connected remote clients;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/162b26b027a5
Test runtime is still connected after about:debugging reload;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/f0c4ce1b0cf9
Reuse clients from remote client manager in about:devtools-toolbox;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/5cda18843d7b
Clear clients stored in remote client manager after tests;r=daisuke,ladybenko
https://hg.mozilla.org/integration/autoland/rev/99da1452e409
Remove transportDetails from runtimeDetails;r=daisuke,ladybenko
Duplicate of this bug: 1501164
You need to log in before you can comment on or make changes to this bug.