Closed Bug 1497498 Opened 3 years ago Closed 3 years ago

The "CFR Recommendation" add-ons cannot be installed anymore

Categories

(Firefox :: Messaging System, defect, P1)

Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1497261
Iteration:
64.2 - Sep 28
Tracking Status
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- affected

People

(Reporter: mcoman, Assigned: andreio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image rec of the issue.gif
[Affected versions]:
- Firefox 64.0a1 Build ID - 20181008220129

[Affected Platforms]:
- All Windows
- All Linux
- All Mac

[Prerequisites]:
- Have a new Firefox profile.
- Have the "browser.search.region" pref set to "US" in the "about:config" page.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Open a new tab and click the "YouTube" Top Site.
3. Repeat step two another 4 times and restart the browser.
4. Open another tab and click the "YouTube" Top Site again.
5. Click the "CFR Recommendation" button from the right part of the "Address Bar".
6. Click the doorhanger's "Add Now" button and observe the behavior.

[Expected result]:
- The add-on's install doorhanger is triggered.

[Actual result]:
- Nothing happens.

[Regression window]:
Last good revision: 2d5a9a9d3baa744707c58eec07f9c20e65869d30
First bad revision: 4a0b6cfb51a1bd90eed7475b0ee06b0e1092fe10
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2d5a9a9d3baa744707c58eec07f9c20e65869d30&tochange=4a0b6cfb51a1bd90eed7475b0ee06b0e1092fe10

Form the pushlog it looks that Bug 1496457 has caused the regression.

[Notes]:
- This issue is also reproducible with the other add-on recommendations.
- Attached a screen recording of the issue.
I believe this was caused by Bug 1496357 and will be fixed by Bug 1497261
Depends on: 1497261
Assignee: nobody → andrei.br92
Status: NEW → RESOLVED
Iteration: --- → 64.2 (Sep 28)
Closed: 3 years ago
Priority: -- → P1
Resolution: --- → DUPLICATE
Duplicate of bug: 1497261
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.